CVE-2019-17571 Apache Log4j Vulnerability

Severity: Medium2020-01-23

Abstract

On December 19, 2019, Apache Software Foundation (ASF) officially released a security advisory, announcing that Apache Log4j has a deserialization issue that could cause remote code execution (CVE-2019-17571). Log4j is a Java-based open-source logging tool that includes a SocketServer class which can easily accept serialized log events and deserialize them without authentication. With the aid of deserialization tools, an attacker could use this class to remotely execute arbitrary code. This affects Log4j versions up to 1.2 up to 1.2.17. A similar flaw found in Log4j 2.x has been assigned CVE-2017-5645.

Multiple Oxygen XML products incorporate Apache Log4j as third party library. This advisory was opened to address the potential impact on this third party library vulnerability.

Affected Products/Versions

ProductSeverityFixed Release Availability
Oxygen XML Editor 21.1 and older versionsMediumOxygen XML Editor 22.0 build 2020021016
Oxygen XML Developer 21.1 and older versionsMediumOxygen XML Developer 22.0 build 2020021016
Oxygen XML Author 21.1 and older versionsMediumOxygen XML Author 22.0 build 2020021016
Oxygen XML WebHelp 21.1 and older versionsMediumOxygen XML WebHelp 22.0 build 2020021107
Oxygen PDF Chemistry 21.1 and older versionsMediumOxygen PDF Chemistry 22.0 build 2020021208
Oxygen XML Web Author 21.1.1 and older versionsMediumOxygen XML Web Author 22.0.0 build 2020021023
Oxygen Content Fusion 1.2 and older versionsMediumOxygen Content Fusion 2.0 build 2020021116

If your license key covers version 22.0, download the latest installation kit that includes this fix.

If your license key covers one of the supported versions older than 22.0 (End of Life (EOL) Policy Statement), contact us at to obtain a patched version of the affected library.

Mitigation

None

Detail

CVE-2019-17571

Severity: High

CVSS Score: 9.8

Log4j third-party library used by Oxygen XML software products is an affected version mentioned in CVE-2019-17571 vulnerability description. However, the Log4j capability to access remote logs through its SocketServer class (where the vulnerability exists) is not enabled and used in Oxygen XML software products. Log4j is used for basic logging within our applications. Therefore Oxygen XML software products are not impacted by CVE-2019-17571.

Revision History

Syncro Soft will continue to update this advisory as additional information becomes available.

If you have questions about the security features of an Oxygen product or require technical support, please contact us on .

If you want to download product updates, please visit our Download page.

Please only use the e-mail address for reporting security issues.