Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Post here questions and problems related to oXygen frameworks/document types.
Johann
Posts: 66

Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Thu Jun 30, 2016 6:46 pm

Hello everyone,

I have just upgraded my oxygen SDK from 17.1.0.1 to 18.0.0.2 and I got an error here :

Code: Select all

// Getting the component factory
AuthorComponentFactory factory = AuthorComponentFactory.getInstance();

// Create the AuthorComponent
String[] editors = {EditorPageConstants.PAGE_AUTHOR, EditorPageConstants.PAGE_TEXT};
authorComponentProvider = (AuthorComponentProvider) factory.createEditorComponentProvider(editors, EditorPageConstants.PAGE_TEXT);


Code: Select all

factory.createEditorComponentProvider(editors, EditorPageConstants.PAGE_TEXT);

returns a 'java.lang.ExceptionInInitializerError' exception.


Any idea about this error ?

Thanks for your help,

Johann
Radu
Posts: 5563

Re: Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Thu Jun 30, 2016 6:57 pm

Hi Johann,

Could you post the entire exception stack trace? You can do for example a try{} catch around that code, catch Exception and log it.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Johann
Posts: 66

Re: Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Thu Jun 30, 2016 7:08 pm

Hi Radu,

Here is the stack trace :

Code: Select all

java.lang.ExceptionInInitializerError
   at ro.sync.exml.editor.pagetext.d.<init>(Unknown Source)
   at ro.sync.exml.editor.validate.l.<init>(Unknown Source)
   at ro.sync.exml.editor.xmleditor.e.g.<init>(Unknown Source)
   at ro.sync.exml.editor.xmleditor.e.k.<init>(Unknown Source)
   at ro.sync.exml.editor.xmleditor.e.j$1.<init>(Unknown Source)
   at ro.sync.exml.editor.xmleditor.e.j.d(Unknown Source)
   at ro.sync.exml.editor.xmleditor.xb.createTextPage(Unknown Source)
   at ro.sync.ecss.extensions.api.component.AuthorComponentProvider$3.createEditorPages(Unknown Source)
   at ro.sync.exml.editor.ec.initFrame(Unknown Source)
   at ro.sync.exml.editor.validate.q.initFrame(Unknown Source)
   at ro.sync.exml.editor.xmleditor.pb.initFrame(Unknown Source)
   at ro.sync.ecss.extensions.api.component.AuthorComponentProvider.<init>(Unknown Source)
   at ro.sync.ecss.extensions.api.component.AuthorComponentFactory.createEditorComponentProvider(Unknown Source)
   at com._4dconcept.docAdvance.authorNeo.authorComponent.document.OxygenComponent.<init>(OxygenComponent.java:41)
   at com._4dconcept.docAdvance.authorNeo.authorComponent.document.OxygenTab.initOxygenComponent(OxygenTab.java:77)
   at com._4dconcept.docAdvance.authorNeo.authorComponent.document.OxygenTab.<init>(OxygenTab.java:41)
   at com._4dconcept.docAdvance.authorNeo.authorComponent.document.TabsPane.openXmlDocument(TabsPane.java:38)
   at com._4dconcept.docAdvance.authorNeo.authorComponent.CustomPluginWorkspace.open(CustomPluginWorkspace.java:150)
   at com._4dconcept.docAdvance.authorNeo.plugin.views.AbstractOpenerWorker.openSelectedS1000DDocument(AbstractOpenerWorker.java:105)
   at com._4dconcept.docAdvance.authorNeo.plugin.views.AbstractOpenerWorker.open(AbstractOpenerWorker.java:85)
   at com._4dconcept.docAdvance.authorNeo.plugin.views.AbstractOpenerWorker.doInBackground(AbstractOpenerWorker.java:69)
   at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
   at java.util.concurrent.FutureTask.run(FutureTask.java:266)
   at javax.swing.SwingWorker.run(SwingWorker.java:334)
   at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
   at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
   at ro.sync.ui.application.menu.g.<clinit>(Unknown Source)
   ... 27 more
   


Johann
Radu
Posts: 5563

Re: Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Thu Jun 30, 2016 7:19 pm

Hi Johann,

I think we fixed this problem in our code a couple of days ago.
It does not occur on every machine, we reproduced this on Ubuntu with a certain Java version.
I will double check and try to launch another SDK version in a day or two. I will update this post when this happens.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Radu
Posts: 5563

Re: Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Fri Jul 01, 2016 11:54 am

Hi Johann,

We just released version 18.0.0.3 of our Maven SDK:

https://www.oxygenxml.com/oxygen_sdk_maven.html

Could you give it a try?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Johann
Posts: 66

Re: Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Fri Jul 01, 2016 3:36 pm

Hi Radu,

It works again with the 18.0.0.3 version.

Thank you for your responsiveness,

Johann
Radu
Posts: 5563

Re: Error when upgrading authorComponent from 17.1.0.1 to 18.0.0.2

Fri Jul 01, 2016 3:38 pm

Hi Johann,

Great, the entire list of bug fixes is available here:

https://www.oxygenxml.com/build_history.html#2016062718

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “SDK-API, Frameworks - Document Types”

Who is online

Users browsing this forum: No registered users and 2 guests