Few issues with WebHelp DocBook publication

Drumminman
Posts: 6
Joined: Fri Jan 22, 2016 2:52 pm

Few issues with WebHelp DocBook publication

Post by Drumminman »

Hi again)
This time I'm using 24.1-version of WebHelp Classic for DocBook transformation scenario, with a bit customized DocBook scheme.
And rn I have few issues during debugging publication.
1. The path to pictures files. I have a master MainImage.xml file via <book>, which consists from a number of <xinclude> to the sectons and topics files, (for example, to the fnTrafficLight.instructions.xml).
Image
oxygenAuthor24.1_qZZ6cGNpDB.png
oxygenAuthor24.1_qZZ6cGNpDB.png (31.86 KiB) Viewed 947 times
For each section/topic xml-file there is /_img dir, located at the same directory, as xincluded file, with all pictures, used in this file.
In Author Mode the MainImage.xml is rendered without any problems at all, but after starting publication, I have such messages for all pictures files in log:

Code: Select all

    [xslt] Failed to load image: ../../Entire/Entire/Fn/fnBasics/_img/STD/appCorp.frmOneTimePass_new.png
So, is there some kind of parameter or propety which sets up the relative base path, cuz this one is very strange
Drumminman
Posts: 6
Joined: Fri Jan 22, 2016 2:52 pm

Re: Few issues with WebHelp DocBook publication

Post by Drumminman »

Well, I had decided the issue with paths - the problem was in few xincludes, pointed to the root elements, and cuz of that final paths were calculated wrong. And now publication is passing good, except one little problem:

Code: Select all

create-main-files:
     [xslt] Processing C:\Program Files\Oxygen XML Editor 24\frameworks\docbook\xsl\com.oxygenxml.webhelp.classic\build.xml to D:\GIT\d2sme_db5\Release\webhelp\dummy.html
     [xslt] Loading stylesheet C:\Program Files\Oxygen XML Editor 24\frameworks\docbook\xsl\com.oxygenxml.webhelp.classic\xsl\docbook\createMainFiles.xsl
     [xslt]  write index frames in: index_frames.html
     [xslt] ERROR: The[color=#FF0000] 'resources/plugins.xml' r[/color]esource is not available.
What is this plugins.xml and where it could be found? Or where it should be? Cuz of that error, as I suppose, frame mode doesn't work correctly.
cosmin_andrei
Posts: 109
Joined: Mon Jun 12, 2017 10:50 am

Re: Few issues with WebHelp DocBook publication

Post by cosmin_andrei »

Hello,
Thank you for your feedback!
We would appreciate if you could send us a sample file for which the issue is reproducible (using either the online support form or the official support email - support [at] oxygenxml [dot] com).
Regards,
Cosmin
--
Cosmin Andrei
oXygen XML Editor and Author Support
Drumminman
Posts: 6
Joined: Fri Jan 22, 2016 2:52 pm

Re: Few issues with WebHelp DocBook publication

Post by Drumminman »

cosmin_andrei wrote: Mon Nov 28, 2022 5:59 pm Hello,
Thank you for your feedback!
We would appreciate if you could send us a sample file for which the issue is reproducible (using either the online support form or the official support email - support [at] oxygenxml [dot] com).
Ну, поскольку с путями я уже вроде как разобрался, то проблема остается только в том, как отрабатывает функции create-main-files.
Я могу предоставить только относительно пустой образ, с "рыбой" вместо содержания, по очевидным причинам.
К слову, обратили еще внимание на то, что в web help classic не работает вторая строка поиска:
Image
Или она работает только для справок, собранных в DITA?
Attachments
изображение.png
изображение.png (5.98 KiB) Viewed 603 times
cosmin_andrei
Posts: 109
Joined: Mon Jun 12, 2017 10:50 am

Re: Few issues with WebHelp DocBook publication

Post by cosmin_andrei »

Hi,
Note that we do not offer support in other language than English.
Also, we would appreciate if you could send us a sample file for which the issue is reproducible (using either the online support form or the official support email - support [at] oxygenxml [dot] com).
Regards,
Cosmin
--
Cosmin Andrei
oXygen XML Editor and Author Support
Post Reply