keywords in conrefs not resolving

axhxu
Posts: 42
Joined: Thu Aug 27, 2015 9:28 pm

keywords in conrefs not resolving

Post by axhxu » Fri Apr 02, 2021 3:33 am

Just wondering if you know of a fix for this issue in the DITA-OT code:

https://github.com/dita-ot/dita-ot/issu ... -container

We have upgraded to the oxygenxml 23.1 and the oxygenxml webhelp responsive output and have encountered this issue and is a blocking issue for us to release the upgrade for our dita CMS publishing solution.

Radu
Posts: 7528
Joined: Fri Jul 09, 2004 5:18 pm

Re: keywords in conrefs not resolving

Post by Radu » Fri Apr 02, 2021 8:17 am

Hi,

For now the fix is to add all your topics which contain reusable content to the DITA Maps setting the processing-role=resource-only attribute on the topicrefs.
We are working on a fix for the DITA Open Toolkit bundled with Oxygen and for the Oxygen publishing engine (our custom DITA OT installation):
https://www.oxygenxml.com/publishing_engine.html
If all goes well, an Oxygen 23.1 minor bug fix release containing the fix will be available in a couple of weeks and we'll update this forum thread when the fix is available. But I cannot guarantee a fix for this will be included in the DITA OT downloaded from the DITA OT web site as we do not control this aspect and also because this problem can be avoided by referencing all your topics in the DITA Maps, which is a DITA best practice.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Radu
Posts: 7528
Joined: Fri Jul 09, 2004 5:18 pm

Re: keywords in conrefs not resolving

Post by Radu » Tue Apr 13, 2021 12:49 pm

Hi,

The Oxygen 23.1 minor bug fix release which includes the fix described above is now available on our website:
https://www.oxygenxml.com/build_history.html#2021040908

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply