Newly installed fonts not populating

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
whyme
Posts: 70
Joined: Fri Mar 08, 2013 8:58 am

Newly installed fonts not populating

Post by whyme » Wed Jul 15, 2020 5:03 pm

On a Windows 10 machine I've installed three different fonts (GFS Didot, Minion Pro, Iosevka) of different types (ttf, ttc, otf), and none of these appear as font preference options in oXygen vv. 20-22, after multiple opens and closes. But the fonts do in other software. Any suggestions?

adrian
Posts: 2659
Joined: Tue May 17, 2005 4:01 pm

Re: Newly installed fonts not populating

Post by adrian » Wed Jul 15, 2020 6:02 pm

Hello,

Please see this topic:
Cannot Select Installed Font in Preferences
Oxygen is a Java application. Most likely Java does not detect the font you have installed.
How did you install the font? Did you use "Install for me" or "Install for all users"?
AFAIK, Java only sees the font if you have used "Install for all users".

BTW, have you tried restarting Windows, after installing the font?
Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

whyme
Posts: 70
Joined: Fri Mar 08, 2013 8:58 am

Re: Newly installed fonts not populating

Post by whyme » Thu Jul 16, 2020 6:12 am

Thanks! That worked, and I didn't have to reboot.

As a note to those coming across this post: if when you right-click on a font you do not see the option "Install for all users" here are two possible reasons + fixes:
  • The font file you've chosen is already installed in C:\Windows\Fonts. Move the file to another location, then right click and look for the option to install for all users.
  • The font type has been associated with a specific program that prevents it from being recognized primarily as a font file. Right click and choose "Open with...". Choose Windows Font Viewer, and click "Always use this app to open * files."

Post Reply