Weird autocomplete bug in v 22.0

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
martindholmes
Posts: 156
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Weird autocomplete bug in v 22.0

Post by martindholmes » Tue Mar 24, 2020 5:59 pm

Hi there,

In 22.0, build 2020030607, working in Text mode on XSLT with master files enabled, I'm seeing a very weird and quite annoying autocomplete bug. I have a single accumulator named "lineCount" defined in the master file:

Code: Select all

  <xsl:accumulator as="xs:integer" initial-value="0" name="lineCount">
    <xsl:accumulator-rule
      match="div[@type='scene']" phase="start"
      select="0"/>
    <xsl:accumulator-rule
      match="sp[ancestor::div[@type='scene']]/p | sp//l[ancestor::div[@type='scene']][@part='I' or not(@part)]"
      select="$value + 1"/>
  </xsl:accumulator>
and now whenever I type any XPath opening string delimiter (I usually use a single quote), 'lineCount' is automatically filled in; it's not even offered as an option I could reject, it just gets inserted automatically. I've never seen this bug before, but this may be the first time for a long time that I'm using an accumulator, so maybe it's been there for a while.

martindholmes
Posts: 156
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Re: Weird autocomplete bug in v 22.0

Post by martindholmes » Wed Mar 25, 2020 8:10 pm

Can anyone else confirm this? It's REALLY annoying, so I've had to turn off content completion for XPath, which is a drag. This is on Ubuntu 18.04.4, using the Oxygen bundled with OpenJDK.

tavy
Posts: 235
Joined: Thu Jul 01, 2004 12:29 pm

Re: Weird autocomplete bug in v 22.0

Post by tavy » Thu Mar 26, 2020 9:45 am

Hello,

Thanks for your feedback.
Yes, this seems to be a problem. I added an issue on our issue tracker to analyze it and find a solution. We will update this thread when will be fixed.
I reproduce this behaviour also with <oXygen/> XML Editor 21.1, build 2019090904. It seems that this happens because 'lineCount' is the only proposal form XPath content completion that starts with a quote, and we consider that should be inserted automatically. If there are more accumulators, then you will get a list with all the names of the accumulators when you insert a quote, but if there is only one it will be inserted automatically. We need to correct this, the quote should be ignored and the proposal should not be inserted.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

martindholmes
Posts: 156
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Re: Weird autocomplete bug in v 22.0

Post by martindholmes » Thu May 07, 2020 9:06 pm

I'd really appreciate a fix for this. It's driving me nuts. :-)

martindholmes
Posts: 156
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Re: Weird autocomplete bug in v 22.0

Post by martindholmes » Thu May 21, 2020 5:01 pm

Please tell me this is fixed in 22.1!

tavy
Posts: 235
Joined: Thu Jul 01, 2004 12:29 pm

Re: Weird autocomplete bug in v 22.0

Post by tavy » Fri May 22, 2020 11:30 am

Hello,

Unfortunately this issue was not solved in Oxygen 22.1. It is scheduled to be solved with priority on the current version. Depending on the complexity we will add it also in an Oxygen 22.1 maintenance build. We will update this thread when will be fixed.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

martindholmes
Posts: 156
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Re: Weird autocomplete bug in v 22.0

Post by martindholmes » Mon Jun 15, 2020 5:33 pm

Is it in today's release? I don't see anything specific in the release notes, although the first item looks a bit similar.

tavy
Posts: 235
Joined: Thu Jul 01, 2004 12:29 pm

Re: Weird autocomplete bug in v 22.0

Post by tavy » Tue Jun 16, 2020 8:25 am

Hello,

No, it it not fixed in the current maintenance release of Oxygen 22.1 (Build ID: 2020061102). It will be fixed in the next maintenance release. The issue is already fixed on the current development stream and it will be integrated also in the next maintenance release.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

martindholmes
Posts: 156
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Re: Weird autocomplete bug in v 22.0

Post by martindholmes » Tue Aug 04, 2020 6:22 pm

According to my testing, this is fixed in the 2020072902 release. Thanks indeed! Please feel free to close this if you're sure everything is dealt with.

tavy
Posts: 235
Joined: Thu Jul 01, 2004 12:29 pm

Re: Weird autocomplete bug in v 22.0

Post by tavy » Thu Aug 06, 2020 9:02 am

Hi,

Yes, the issue was fixed in the latest maintenance build of Oxygen XML Editor 22.1.
https://www.oxygenxml.com/build_history.html#2020072902

Thanks again for your feedback.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply