Can't comment out DITA that contains double dash --

<oXygen/> general issues.
morrisonmc
Posts: 1
Joined: Fri Dec 20, 2019 10:47 pm

Can't comment out DITA that contains double dash --

Post by morrisonmc » Sat Dec 21, 2019 12:39 am

In the oXygen XML Editor Author mode, when I click the Toggle Comment button to comment out a part of my DITA document, I see the following error message:

Code: Select all

 The character sequence '--' is not permitted within comments
Here's part of what I was trying to comment out:

Code: Select all

<xref href="#xd_179f5ba22902868a-28cc585f-140514b5b56--7eae/step_zfy_3kx_bkb" format="dita"/>
And, indeed, there is a double dash -- in the href for the xref. The double dash comes from the base topic's ID:

Code: Select all

<task xmlns:ditaarch="http://dita.oasis-open.org/architecture/2005/" id="xd_179f5ba22902868a-28cc585f-140514b5b56--7eae" xml:lang="en-US">
My question: can I change the way that oXygen adds auto-generated IDs to not include a double dash in the ID? If the ID has no double dash, I can easily comment out any section of a DITA document. As it is, there are many parts of a document that I cannot comment out. I did not see any option or preference that controls auto-generated IDs.

From this forum, I saw that oXygen is supposed to convert the -- to an escaped-string (such as -\-) to allow commenting to work. However, I do not see this behavior. I have oXygen XML Editor 18.0.

-- Michael

alex_jitianu
Posts: 732
Joined: Wed Nov 16, 2005 11:11 am

Re: Can't comment out DITA that contains double dash --

Post by alex_jitianu » Mon Dec 30, 2019 12:18 pm

Hi Michael,
From this forum, I saw that oXygen is supposed to convert the -- to an escaped-string (such as -\-) to allow commenting to work. However, I do not see this behavior. I have oXygen XML Editor 18.0.
It's not related to the Oxygen version. This behavior is present only in the text page. So just switch to the text page, select the topic and invoke the Toggle Comment action from the contextual menu. Please note that when you decide to un-comment the section you'll need to use the action from the text page as well, because the one from the author page doesn't know how to remove that escaping backslash.

We intend to improve the Toggle Comment action from the author page as well, so I will add your vote for it. As soon as we address it, we will post a notice on this thread.

Best regards,
Alex

Post Reply