Copy/Paste fail when XML contains comment

Post here questions and problems related to oXygen frameworks/document types.
Johann
Posts: 60

Copy/Paste fail when XML contains comment

Fri Oct 14, 2016 7:24 pm

Hi,

I am using the Oxygen SDK 18.0.0.3. When I copy an XML fragment containing a comment (<!-- example -->) from an author view to the same or to another author view, nothing is pasted.

For information, when I paste the same fragment to Notepad++ for example, I retrieve at least the text content.

It works in Oxygen 18.

Do you think this issue can come from Author Component ?

Thanks for your response,

Johann
alex_jitianu
Posts: 604

Re: Copy/Paste fail when XML contains comment

Mon Oct 17, 2016 11:08 am

Hi Johann,

The fragment contains just that XML comment? Is there any exception or error message present inside the console? I tried to reproduce this behavior but in my case it worked as expected. I've tested on the sample Author Component project on which I've made sure the SDK version is 18.0.0.3:

Code: Select all

<oxygen.sdk.version>18.0.0.8</oxygen.sdk.version>

The latest SDK version is 18.0.0.8. Do you get the same behavior with this version too? The Author Component, are you running it as an Applet or in a standalone application?

Best regards,
Alex

Return to “SDK-API, Frameworks - Document Types”

Who is online

Users browsing this forum: No registered users and 0 guests