Feedback not working with Oxygen 18.0

bcspendlove
Posts: 12

Feedback not working with Oxygen 18.0

Fri May 06, 2016 7:50 pm

We've been using the webhelp feedback feature for some time. After upgrading to Oxygen 18, transforming, and publishing, comments no longer appear on the pages. The comments are still in the database, but existing comments don't show up and new comments are not created and added to the database.

At the bottom of the page, below the "Add new comment" button, a single line of text reads "no page for comment". That's got to have something to do with it, but I don't know what it means. Couldn't find anything in a forum search.

I tried setting up a new database and publishing to that with new tables and everything, but I get the same results.

Anyone else seeing this problem?
bogdan_cercelaru
Posts: 188

Re: Feedback not working with Oxygen 18.0

Mon May 09, 2016 2:08 pm

Hello,

I've tested using the Oxygen version 18.0 using the built in DITA Map WebHelp Responsive with Feedback transformation scenario and I cannot reproduce this issue.
Please try to publish the WebHelp with feedback to a new, empty directory or set the "clean.output" parameter to "yes" and test again.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
bcspendlove
Posts: 12

Re: Feedback not working with Oxygen 18.0

Tue May 10, 2016 12:06 am

Hi Bogdan,

I've tried publishing using the default "DocBook WebHelp Classic with Feedback" transformation to a new output folder. (Note that I'm using DocBook, not DITA.) I've tried both our documentation set and a smaller test set.

I get the same results—a "no page for comment" message below the "Add New Comment" button, and comments don't work. The comment editor does appear when I click "Add New Comment", but after clicking "Submit" nothing happens. The comments don't appear, either on the page or in the database.

I change the following settings when installing:
Anonymous posts are off
Moderation is off
LDAP is off

Let me know if you need any more information.

Thanks,
Ben
bogdan_cercelaru
Posts: 188

Re: Feedback not working with Oxygen 18.0

Tue May 10, 2016 9:47 am

Hi Ben,

Sorry for my mistake.
I was able to reproduce this issue.
To fix this you should edit the "[OXYGEN_DIR]/frameworks/docbook/xsl/com.oxygenxml.webhelp/xsl/docbook/desktop/fixup.xsl" file and comment the following line (line 103):

Code: Select all

<xsl:attribute name="onload">init('<xsl:value-of select="$PATH2PROJ"/>')</xsl:attribute>


This issue will be also fixed in the next maintenance build of Oxygen.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
bcspendlove
Posts: 12

Re: Feedback not working with Oxygen 18.0

Tue May 10, 2016 6:15 pm

Thanks! It's working now. All the comments show up, and new ones can be added.
ionela
Posts: 140

Re: Feedback not working with Oxygen 18.0

Mon May 16, 2016 12:13 pm

Hi,

Just to update the thread this problem has been resolved in the latest maintenance build of Oxygen 18.0, 2016051118 (released on May 13th):
DocBook/WebHelp with Feedback: Feedback engine did not load the comments anymore.

You can download it from our web site:
http://www.oxygenxml.com/download.html

The list of bug-fixes can be found here:
http://www.oxygenxml.com/build_history.html#2016051118

You can follow the release/build RSS feed here:
http://www.oxygenxml.com/rssBuildID.xml

Let us know if you encounter further problems with this new build.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Return to “DocBook”

Who is online

Users browsing this forum: No registered users and 0 guests