[BUG] Chunked webhelp topics have no associated CSS

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
caval
Posts: 25

[BUG] Chunked webhelp topics have no associated CSS

Wed Apr 27, 2016 9:41 pm

When the chunk="to-content" AVP is applied to a topicref with sub-topics in a map, the webhelp output is correctly chunked -- all sub-topics appear on the same page -- but the chunked page has no associated CSS. When a standard Inspect Element tool is used on the page, no associated CSS files are found.

I've identified the problem. In the chunked page, the link elements in the head do not point to the correct CSS directory.

Correct example
<link rel="stylesheet" type="text/css" href="../oxygen-webhelp/resources/css/webhelp_topic.css"><!----></link>
<link rel="stylesheet" type="text/css" href="../oxygen-webhelp/resources/skins/skin.css"><!----></link>

Incorrect (chunked) example
<link rel="stylesheet" type="text/css" href="oxygen-webhelp/resources/css/webhelp_topic.css"><!----></link>
<link rel="stylesheet" type="text/css" href="oxygen-webhelp/resources/skins/skin.css"><!----></link>

Note: Generated with Oxygen version 17.1, build number 2016020417.

In our content, webhelp .html files are in a sub-folder under the main index.html. The CSS reference must back out before pointing to the oxygen-webhelp folder. This is not happening when -- and only when -- the topic is chunked.

Is there a way to fix this situation? We would like to use chunking more in our production webhelp.
caval
Posts: 25

Re: [BUG] Chunked webhelp topics have no associated CSS

Wed Apr 27, 2016 9:47 pm

Addendum: None of the resources on the chunked page are referenced correctly (i.e. CSS and javascript).
bogdan_cercelaru
Posts: 200

Re: [BUG] Chunked webhelp topics have no associated CSS

Thu Apr 28, 2016 10:00 am

Hello,

I've tested using chunk="to-content" for some topics in our sample DITA Map, but I wasn't able to reproduce the issue that you described.
Are you using the built-in DITA Map WebHelp transformation scenario or a custom one?
Please send us an email on support@oxygenxml.com with a sample DITA Map and the corresponding topics.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
pault
Posts: 62

Re: [BUG] Chunked webhelp topics have no associated CSS

Mon May 02, 2016 12:41 am

When testing WebHelp Responsive in Oxygen 18, I have noticed the same problem. The problem I'm seeing is that the chunked topic CSS and JS are not pointing to the right place, although the relative links are the same. For example, both chunked to-content and no chunk show:

Code: Select all

<link rel="stylesheet" type="text/css" href="../oxygen-webhelp/resources/css/commonltr.css" />


However the absolute URL is wrong in the chunked to-content. It points to:

Code: Select all

view-source:file:///Users/me/docs/oxygen-webhelp/resources/css/commonltr.css


When it should be pointing to

Code: Select all

view-source:file:///Users/me/docs/out/webhelp-responsive/oxygen-webhelp/resources/css/commonltr.css
radu_pisoi
Posts: 319
Location: Craiova

Re: [BUG] Chunked webhelp topics have no associated CSS

Tue May 03, 2016 2:16 pm

Hi,

I was able to reproduce this issue both with DITA-OT 1.8 and 2.2. But, depending on the DITA-OT version and how the DITA topics are referenced (keyrefs or direct links), the way you can reproduce it is slightly different.

Using the direct reference mechanism like in the following sample:

Code: Select all

<topicref href="Topics/T1.dita" chunk="to-content">
  <topicref href="Topics/T2.dita"/>
</topicref>

the references to the CSS and JS files are broken only when using the DITA-OT 1.8. For this problem we found a solution and it will be fixed in the next oXygen maintenance build.

If I've used the keyref mechanism:

Code: Select all

<keydef href="Topics/T1.dita" keys="T1"/>
 <keydef href="Topics/T2.dita" keys="T2"/>
 
 <topicref keyref="T1" chunk="to-content">
  <topicref keyref="T2" toc="no"/>
 </topicref>

the issue can be reproduced with both DITA-OT versions.
For this situation we don't have a fix or an workaround. We added an issue to the DITA-OT project that we depend to create the Webhelp output:
https://github.com/dita-ot/dita-ot/issues/2298
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
pault
Posts: 62

Re: [BUG] Chunked webhelp topics have no associated CSS

Tue May 03, 2016 10:12 pm

Thanks Radu.
Frank Ralf
Posts: 350
Location: Hamburg

Re: [BUG] Chunked webhelp topics have no associated CSS

Wed Jul 06, 2016 2:53 pm

JFTR, see also "WebHelp: Chunking breaks CSS paths" where the problem was caused by an old DITA-OT version (1.8.4?).

Frank
Frank Ralf
parson AG
www.parson-europe.com

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 2 guests