Webhelp Transformation issue

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
hendersj
Posts: 8
Joined: Sat Nov 15, 2014 2:24 am

Webhelp Transformation issue

Post by hendersj » Sat Nov 15, 2014 2:33 am

Hi,

I'm relatively new to oXygen, but really liking it a lot. I've just converted a couple hundred pages for documentation stored in a Confluence server to DITA and oXygen did brilliantly with the import as well as the process of helping clean up lots of content that wasn't developed following a lot of standards.

I've just run a webhelp + feedback transformation, and every file in the ditamap transformed except for one, and I can't figure out what's wrong.

The file isn't named weirdly (it's just Key_Pairs.dita), but for some reason, when the transformation engine hits that file, it throws up the following errors:

Code: Select all

System ID: /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap
Scenario: DITA Map WebHelp with Feedback
Input file: /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap
Document type: DITA Map
Engine name: DITA-OT
Severity: warning
Description: [DOTX023W]: Unable to retrieve navtitle from target: 'Key_Pairs.dita'. The location of this problem was at (File = /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap, Element = topicref:74;98:50)
Start location: 98:50
URL: http://www.oxygenxml.com/DITA-messages.html#msgs__DOTX023W

System ID: /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap
Scenario: DITA Map WebHelp with Feedback
Input file: /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap
Document type: DITA Map
Engine name: DITA-OT
Severity: warning
Description: [DOTX027W]: Unable to retrieve linktext from target: 'Key_Pairs.dita'. The location of this problem was at (File = /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap, Element = topicref:74;98:50)
Start location: 98:50
URL: http://www.oxygenxml.com/DITA-messages.html#msgs__DOTX027W

System ID: /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap
Scenario: DITA Map WebHelp with Feedback
Input file: /Users/jhenderson/Documents/PA30R2-DITA/PingAccess.ditamap
Document type: DITA Map
Engine name: DITA-OT
Severity: error
Description: [DOTX008E] File '/Users/jhenderson/Documents/PA30R2-DITA/temp/webhelp-feedback/Key_Pairs.dita' does not exist or cannot be loaded.
URL: http://www.oxygenxml.com/DITA-messages.html#msgs__DOTX008E
There are 19 other errors reported, all relating to xrefs to this file that are not resolvable.

I checked the temp directory indicated in the last message while the file was being generated, and the Key_Pairs.dita file did not exist (nor did a Key_Pairs file with any extension).

All files are in the local filesystem, in the directory where the ditamap and project files are located. The file validates just fine as a DITA Topic, and is included in the ditamap as a topicref. The files that represent the sections before and after this one show no issues - just this one file won't transform.

In the final webhelp output, I get html files for everything, but this file is copied as a .dita file into the directory. It's not transformed - it's the same file as in my project directory.

How do I troubleshoot and resolve this issue?

Using oXygen XML Author 16.1 on OSX Mavericks.

Thanks,

Jim

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Webhelp Transformation issue

Post by sorin_ristache » Mon Nov 17, 2014 4:14 pm

Hi Jim,

First you should run on the DITA map PingAccess.ditamap the action called Validate and Check for Completeness available on the toolbar of the DITA Maps Manager view. Does this action report any errors? If yes please fix them before running a DITA transformation on the map.
hendersj wrote:In the final webhelp output, I get html files for everything, but this file is copied as a .dita file into the directory. It's not transformed - it's the same file as in my project directory.
What is different in the topicref element that includes Key_Pairs.dita in the map? Maybe an additional attribute like processing-role="resource-only"? We want to find out why this topic file is not processed in the same way as the other ones included in the same map.

Is this topic file Key_Pairs.dita located in the same directory with the map just as the rest of the topics? If it is located outside the directory with the DITA map please set the transformation parameter called fix.external.refs.com.oxygenxml to value true.

If these suggestions don't help please send us a set of sample files for reproducing the problem: a sample DITA map and all the topics included in it.
Regards,
Sorin

<oXygen/> XML Editor Support

hendersj
Posts: 8
Joined: Sat Nov 15, 2014 2:24 am

Re: Webhelp Transformation issue

Post by hendersj » Mon Nov 17, 2014 8:11 pm

Thanks, Sorin -

I've run the validation on the files, and everything validated OK.

I did try copying the .dita file into the temp directory during generation, and that actually worked - I got a proper transformation, so it just seems that the file isn't getting copied to the project's temp directory for some reason, but I can't see why. There's plenty of free disk space.

In the ditamap file, there's nothing about the topicref different from others in the list - the relevant segment includes:

Code: Select all

                <topicref href="Clustering.dita"/>
<topicref href="Key_Pairs.dita"/>
<topicref href="Certificates.dita"/>
<topicref href="HTTPS_Listeners.dita"/>
Clustering.dita, Certificates.dita, and HTTPS_Listeners.dita all are processed correctly. All the dita files are located in the same directory as the ditamap.

I'll take a little time this morning and send you a sample that includes the problem file, one that works, and the ditamap (reduced down to just the two files that show the working/not working).

Thanks!

hendersj
Posts: 8
Joined: Sat Nov 15, 2014 2:24 am

Re: Webhelp Transformation issue

Post by hendersj » Mon Nov 17, 2014 8:39 pm

Found the problem.

In the process of stripping out content to provide a minimal set of content showing the problem, I found that the file actually had a cross-reference to itself (in the 'related links' section) with an extra attribute on the link element:

format="html"

Removing that attribute has resolve the issue for me. It probably snuck in during my automated conversion from Confluence, and for some reason, that was the only place this showed up.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Webhelp Transformation issue

Post by sorin_ristache » Tue Nov 18, 2014 11:13 am

Thank you for letting us know.
Regards,
Sorin

<oXygen/> XML Editor Support

dchapman
Posts: 18
Joined: Mon Jul 29, 2013 8:57 pm

Re: Webhelp Transformation issue

Post by dchapman » Thu Jan 29, 2015 11:19 pm

Hi,

I'm hoping to export page content out of Confluence into DITA. I read your statement " I've just converted a couple hundred pages for documentation stored in a Confluence server to DITA and oXygen did brilliantly with the import as well as the process of helping clean up lots of content that wasn't developed following a lot of standards."

Could you share your process?

Cheer and thanks,
Diana

hendersj
Posts: 8
Joined: Sat Nov 15, 2014 2:24 am

Re: Webhelp Transformation issue

Post by hendersj » Fri Jan 30, 2015 1:09 am

I was working with Confluence 3.5; basically, the procedure involved using Confluence's built-HTML-export.

After running the HTML-export, I converted it to XHTML using html2xhtml (from http://www.it.uc3m.es/jaf/html2xhtml/), and then oXygen's XHTML import to get to DITA. As I recall, I then built the ditamap mostly by hand, but I did a little bit of ad-hoc scripting to get the basic ditamap structure set up.

There's been a bit of cleanup, and everything is a topic, so there's still some work to do, but I ended up with a pretty usable set of topics as a starting point.

Something that I have noticed is that our particular Confluence structure used what ended up being tables to do tips/notes/warnings, and those are going to require some work to convert, but that was something specific to how the pages in confluence were created for our setup.

dchapman
Posts: 18
Joined: Mon Jul 29, 2013 8:57 pm

Re: Webhelp Transformation issue

Post by dchapman » Fri Jan 30, 2015 5:31 pm

Thanks so much for all the information and the quick response! It'll be interesting to try to get good enough results without an onerous amount of manual intervention. Of course I realize there will be some degree of tweaking. I'm really just looking to round-trip from DITA to Confluence for technical content review processes and somehow "pull" content from Engineering pages. Thankfully I have a lull before deliverables are due to trial and error. Again, thanks so much//1 :D

hendersj
Posts: 8
Joined: Sat Nov 15, 2014 2:24 am

Re: Webhelp Transformation issue

Post by hendersj » Fri Jan 30, 2015 7:21 pm

Glad to help out. :)

Post Reply