confirmation email for webhelp with feedback doesn't work

<oXygen/> general issues.
tomjohnson1492
Posts: 132
Joined: Thu Apr 17, 2014 1:55 am

confirmation email for webhelp with feedback doesn't work

Post by tomjohnson1492 » Fri Jan 09, 2015 8:09 pm

I have oxygen webhelp with feedback integrated. When a user signs up for an account in order to comment, an email validation is sent. However, when the user clicks the link in the validation email, it goes to a blank page. Here's a sample validation link:

http://mysite.com/sampleproject/oxygen- ... E3OjA4OjIz

I just get a blank page when I try to go to these emails. (Note: I edited the root path here for privacy reasons.)

Any idea why this isn't working?

tomjohnson1492
Posts: 132
Joined: Thu Apr 17, 2014 1:55 am

Re: confirmation email for webhelp with feedback doesn't wor

Post by tomjohnson1492 » Fri Jan 09, 2015 9:15 pm

I wish this commenting feature weren't so buggy and fragile.

tomjohnson1492
Posts: 132
Joined: Thu Apr 17, 2014 1:55 am

Re: confirmation email for webhelp with feedback doesn't wor

Post by tomjohnson1492 » Sat Jan 10, 2015 9:24 pm

If you have a fix for this, let me know. I have about 20 people who will be reviewing documentation on Monday and I've told them to comment anonymously, without logging in. I tried changing the file permissions to everything in the oxygen-webhelp directory to 777, but it had no effect. The confirm.html file just shows a blank page. I tried in chrome, FF, and safari.

tomjohnson1492
Posts: 132
Joined: Thu Apr 17, 2014 1:55 am

Re: confirmation email for webhelp with feedback doesn't wor

Post by tomjohnson1492 » Sat Jan 10, 2015 10:17 pm

Just to confirm that the issue wasn't due to any security restrictions in my environment at work, I created a test webhelp with feedback project here:

http://idratherbewriting.com/webhelpfeedbacktest

Try to sign up to comment on the topic. When you do, you'll get an email telling you to confirm the link:

http://idratherbewriting.com/webhelpfee ... EyOjE1OjI3

The page is blank. I made sure the file permissions is 777 as well as the other permissions for its sibling files in that directory.

The user does get added to the database, but is only added as "created," not "validated." I have to manually go in and validate the user in order for them to receive access.

Do you know that this bug exists with the webhelp with feedback output? Can you tell me what a fix might be? It would be awesome to learn about how to fix this prior to Monday.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: confirmation email for webhelp with feedback doesn't wor

Post by sorin_ristache » Mon Jan 12, 2015 5:07 pm

I successfully signed up with two new different users (user names: sorin and oxygenxml) on the WebHelp page:

http://idratherbewriting.com/webhelpfeedbacktest/

In both cases the links in the email messages were valid because on clicking them I received the message in the browser window that the WebHelp user was successfully created.

In the link that you posted there is a missing '=' character as below, because an id URL parameter should follow the confirm.html file name, as it correctly does in the two email notifications that I received:

...confirm.html?id=M3wyMDE...

It is not clear how the '=' character could be lost in the link in your email notification message, since I received a valid link for both user names that I tried on the same WebHelp-Feedback system as you (your installed system). In order to fix the problem I would need first a way of reproducing it. With what Oxygen build were the WebHelp pages generated? The Oxygen build number is visible in the Help -> About dialog box.
Regards,
Sorin

<oXygen/> XML Editor Support

tomjohnson1492
Posts: 132
Joined: Thu Apr 17, 2014 1:55 am

Re: confirmation email for webhelp with feedback doesn't wor

Post by tomjohnson1492 » Mon Jan 12, 2015 6:22 pm

I just tried signing up again and experienced the same problem. The confirm email is:

Code: Select all

Welcome Shannon [shannon] to the test Webhelp system!
Please click the link below to confirm your registration:
http://idratherbewriting.com/webhelpfeedbacktest/oxygen-webhelp/resources/confirm.html?idNnwyMDE1LTAxLTEyIDA4OjE4OjA4
The provided link is valid only for 7 days!
Your new created account will be valid for these products:
"test"
My oxygen build is <oXygen/> XML Author 16.1, build 2014100319.

Changing the link to add the = does make it work:

Code: Select all

confirm.html?id=NnwyMDE1LTAxLTEyIDA4OjE4OjA4
Why is this = being dropped from my link? In your tests, are you using a gmail account? I did a test where I sent the link manually and the = sign wasn't dropped. I don't know why your tests are keeping the =. Can you explore this more?

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: confirmation email for webhelp with feedback doesn't wor

Post by sorin_ristache » Mon Jan 12, 2015 6:34 pm

I used one email address @sync.ro and another one @oxygenxml.com and both email addresses received an email message with a valid link, which confirmed the WebHelp user name. I can't imagine why a wrong link would be included in your emails. Maybe some filter on the receiving email server might modify the links?

I will look at the links included in the emails generated by WebHelp pages created with Oxygen build 2014100319.
Regards,
Sorin

<oXygen/> XML Editor Support

tomjohnson1492
Posts: 132
Joined: Thu Apr 17, 2014 1:55 am

Re: confirmation email for webhelp with feedback doesn't wor

Post by tomjohnson1492 » Mon Jan 12, 2015 6:37 pm

I even tried it with a prev build (16.0) and got the same result.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: confirmation email for webhelp with feedback doesn't wor

Post by sorin_ristache » Tue Jan 13, 2015 9:53 am

It may be related to a bug which we fixed in the links included in the WebHelp-Feedback email messages in build 2014102117, which is a later build of Oxygen 16.1. Please install the current build of Oxygen 16.1 and generate again the WebHelp pages.
Regards,
Sorin

<oXygen/> XML Editor Support

Post Reply