content completion not working everywhere Oxygen 15.2

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
emylonas
Posts: 10
Joined: Sat Feb 16, 2013 3:04 am

content completion not working everywhere Oxygen 15.2

Post by emylonas » Thu Feb 27, 2014 6:57 pm

I have a framework that makes Author forms. In Oxygen 15.1, it's possible to press return within various elements that have css associated with them to make them visible, and to enter new markup. Also to surround a string of text, press return and then select something from a list of valid elements. In other words content completion is working.

In Oxygen 15.2, content completion works when the cursor is in "in-between" places in the document where markup is allowed -but these aren't places where I want encoders to be typing. But I can't get content completion to work in either form controls of type text, or in paragraphs (<p>) that are simply made visible using css like the following:

Code: Select all


 div[subtype="diplomatic"] > p,  div[subtype="transcription"] > p {        
border:2px solid rgb(153, 153, 143);
background-color:rgb(245, 243, 221);
margin:10px 20px 15px 20px;
display:block;
-oxy-placeholder-content: 'text here';
}
Content completion works when viewing the file in Editor mode. and shows up when i switch back to Author mode. But I can't add any markup in Author mode.

I can send more ex. if this isn't an obvious oversight on my part. Is this a change in 15.2 that I haven't been able to find?

thank you.

alex_jitianu
Posts: 704
Joined: Wed Nov 16, 2005 11:11 am

Re: content completion not working everywhere Oxygen 15.2

Post by alex_jitianu » Fri Feb 28, 2014 11:44 am

Hello,

Our content completion system is based on the information derived from the schema attached to the document. Since it works in the Text page, there is no reason for it not working in Author page. The framework-level configuration can disable the content completion either by using the Content Completion [1] tab in the or by using a SchemaManagerFilter [2].

It would help if you could send us (to our support email address support@oxygenxml.com) the framework you are working with and a sample file on which the problem manifests.

Thanks,
Alex

[1] http://oxygenxml.com/doc/ug-editor/#tas ... etion.html
[2] http://oxygenxml.com/doc/ug-editor/#top ... ndler.html

emylonas
Posts: 10
Joined: Sat Feb 16, 2013 3:04 am

Re: content completion not working everywhere Oxygen 15.2

Post by emylonas » Fri Feb 28, 2014 5:01 pm

This is the framework location:
http://cds.library.brown.edu/projects/I ... -addon.xml

I have checked the content completion in Author and I don't seem to have anything turned off.

I know that it should work in both Editor and Author modes, that is what is confusing me. What is even more confusing is that it only seems to be a problem in 15.2.

I have tried it with your travel sample, and I can get content completion to work there. However, it won't work in my files - either in the form controls or in the paragraphs (the ones labeled "Diplomatic Transcription" etc. towards the bottom of the template file.

Also, - given that it works in 15.1, is it possible to still download that version of Oxygen? It doesn't seem to be on your archive page. that would allow people to keep working until we figure things out!

thanks, --elli

alex_jitianu
Posts: 704
Joined: Wed Nov 16, 2005 11:11 am

Re: content completion not working everywhere Oxygen 15.2

Post by alex_jitianu » Mon Mar 03, 2014 4:49 pm

Hello,

Thank you for the add-on. We've managed to reproduce the problem and the fix will be available in the next 15.2 maintenance build which should be released in a couple of days. This problem has the same root as the problem you reported earlier on the support list, the one with lang attribute: *:lang(en). Version 15.1 can be downloaded from the following locations: Windows or OSX

Best regards,
Alex

emylonas
Posts: 10
Joined: Sat Feb 16, 2013 3:04 am

Re: content completion not working everywhere Oxygen 15.2

Post by emylonas » Mon Mar 03, 2014 5:22 pm

Thank you so much!! I await the next maintenance release eagerly! --elli

ionela
Posts: 297
Joined: Mon Dec 05, 2011 6:08 pm

Re: content completion not working everywhere Oxygen 15.2

Post by ionela » Thu Mar 06, 2014 4:34 pm

Hello,

I just wanted to let you know that this problem has been resolved in the latest maintenance build of Oxygen 15.2, 2014022718 (released on March 4th):
Author: Fixed a NullPointerException that occurred when using in the Author CSS the style '*:lang(en)'
You can download it from our web site:
http://www.oxygenxml.com/download.html

The list of bug-fixes can be found here:
http://www.oxygenxml.com/build_history.html#2014022718

You can follow the release/build RSS feed here:
http://www.oxygenxml.com/rssBuildID.xml

Let us know if you encounter further problems with this new build.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Post Reply