Webhelp Search does not Function on Map Composition

mstrubberg
Posts: 48
Joined: Sat Jan 26, 2013 6:07 pm

Webhelp Search does not Function on Map Composition

Post by mstrubberg » Tue Feb 19, 2013 11:34 pm

I'm using Oxygen 14.2 webhelp output on a <map> file containing six topics. The index_frames.html search does not function but returns a java null error.

When I compose a <bookmap> the webhelp search functions properly.

How can I configure the system to properly allow Search in Webhelp when <map> is the root element?

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Webhelp Search does not Function on Map Composition

Post by sorin_ristache » Wed Feb 20, 2013 2:25 pm

Hello,

The search should work in the same way in the Webhelp output in both the frameset version and the internal frames one. At least that's what we get in our tests. Please send us a zip archive with a set of sample input files (a DITA map and the topics included in the map) and the Webhelp output file. Also specify the search string that you tried on the Search tab.


Regards,
Sorin

mstrubberg
Posts: 48
Joined: Sat Jan 26, 2013 6:07 pm

Re: Webhelp Search does not Function on Map Composition

Post by mstrubberg » Wed Feb 20, 2013 4:19 pm

After further testing, it looks like the webhelp\index_frames.html search is not working when viewed in Internet Explorer version 8.

The same files searched under Chrome version 24 does work properly.

The same files searched using webhelp\index.html works properly under Internet Explorer version 8.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Webhelp Search does not Function on Map Composition

Post by sorin_ristache » Wed Feb 20, 2013 5:21 pm

Hello,

I tested in Internet Explorer 8 the search in both the frameset output and the internal frames output of the Oxygen Webhelp transformation (both index_frames.html and index.html) and it worked correctly. Can you test in IE8 on your computer the search in the User Manual on the Oxygen website? Does it work correctly?


Regards,
Sorin

mstrubberg
Posts: 48
Joined: Sat Jan 26, 2013 6:07 pm

Re: Webhelp Search does not Function on Map Composition

Post by mstrubberg » Wed Feb 20, 2013 10:54 pm

Sorin,

Using IE 8, I went to www.oxygenxml.com/doc/ug-editor/index_frames.html and searched on the keyword "Editor" and got a javascript:void(0) in the progress bar and no search results. I searched other known words to exist like "preferences", "oxygen" and still get a javascript:void(0) and no search results.

These same searches render results in IE 8 using index.html

Is there some setting I'm missing in IE 8 (I can't control the browser or the browser version being used.)

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Webhelp Search does not Function on Map Composition

Post by sorin_ristache » Thu Feb 21, 2013 11:40 am

Hi,

We have to install more builds of Internet Explorer 8 and 9 here on some test machines for reproducing the problem and fixing it because in our builds of IE the search works correctly. The failure of the search is probably caused by a difference in the JavaScript engines embedded in different builds of IE. We will update this forum after we fix it.

Please can you post here a screenshot with the Help -> About box of your Internet Explorer 8 build? We want to make sure that we test with your build too.

To give you an idea of the subtle JavaScript differences in JavaScript engine behavior that underlie this problem: in IE 9 running in IE 8 compatibility mode the Webhelp search is flawless.


Regards,
Sorin

mstrubberg
Posts: 48
Joined: Sat Jan 26, 2013 6:07 pm

Re: Webhelp Search does not Function on Map Composition

Post by mstrubberg » Thu Feb 21, 2013 6:30 pm

Internet Explorer 8
Version: 8.0.7601.17514
Cipher Strength: 256-bit
Update Versions: 0
2009 Microsoft Corporation

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Webhelp Search does not Function on Map Composition

Post by sorin_ristache » Thu Feb 21, 2013 6:39 pm

Thank you for the build number. We will have to test with that too.


Regards,
Sorin

ionela
Posts: 334
Joined: Mon Dec 05, 2011 6:08 pm

Re: Webhelp Search does not Function on Map Composition

Post by ionela » Fri Apr 12, 2013 11:45 am

Hello,

I just wanted to let you know that this problem has been resolved in the latest maintenance build of Oxygen 14.2, 2013040919 (released on April 10th):
WebHelp/IE8/IE9: The search returned no results on some builds of Internet Explorer 8 and 9.
You can download it from our web site:
http://www.oxygenxml.com/download.html

The list of bug-fixes can be found here:
http://www.oxygenxml.com/build_history.html#2013040919

You can follow the release/build RSS feed here:
http://www.oxygenxml.com/rssBuildID.xml

Let us know if you encounter further problems with this new build.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

mstrubberg
Posts: 48
Joined: Sat Jan 26, 2013 6:07 pm

Re: Webhelp Search does not Function on Map Composition

Post by mstrubberg » Fri Oct 18, 2013 6:28 pm

I am now using Oxygen 15.0 and the webhelp output index_frames.html file viewed under IE 9 Search is again functioning.

Thanks for your help.

Post Reply