RTF transform seems incomplete

Post here questions and problems related to oXygen frameworks/document types.
Lemesany
Posts: 19
Joined: Wed Jan 25, 2017 11:21 pm

RTF transform seems incomplete

Post by Lemesany » Wed Apr 04, 2018 8:36 pm

When I try to use the "DITA Map RTF" transform, I get the following error:

Code: Select all

Transformation failed. /Applications/Oxygen XML Author/frameworks/dita/DITA-OT2.x/plugins/org.dita.wordrtf/build_dita2wordrtf.xml:75: javax.xml.transform.TransformerConfigurationException: net.sf.saxon.s9api.SaxonApiException: Errors were reported during stylesheet compilation
build_dita2wordrtf.xml, line 75 is:

Code: Select all

    style="${dita.plugin.org.dita.wordrtf.dir}/xsl/topicmerge.xsl">
Some research led me here: https://github.com/dita-ot/dita-ot/issues/2607 which states:
"Templates that use output-message.xsl must also import dita-utilities.xsl. Add the missing import to your shell stylesheet."

The topicmerge.xsl file uses output-message.xsl. I added line 14 to topicmerge.xsl:

Code: Select all

12 <!-- Include error message template -->
13 <xsl:import href="plugin:org.dita.base:xsl/common/output-message.xsl"/>
14 <xsl:import href="plugin:org.dita.base:xsl/common/dita-utilities.xsl"/>
And the RTF transformation worked.

Is this the right solution? If so, is this a bug that Oxygen could fix in a maintenance build?
In the interim, is there a way I can push this fix to my writers via a customized transform, perhaps, or otherwise? I can't find a place in the default RTF transform Parameters where I could add this line. I've also tried duplicating the org.dita.wordrtf to a custom location so I can comfortably modify the topicmerge.xsl without touching the original, but calling this custom location as a transform option hasn't been working (I pointed the RTF Transform scenario > Advanced > Custom build file to the new location). The build says "successful" after about 1 second but no output appears.

Radu
Posts: 7098
Joined: Fri Jul 09, 2004 5:18 pm

Re: RTF transform seems incomplete

Post by Radu » Wed Apr 11, 2018 4:25 pm

Hi,

Sorry for the delay, I can reproduce the problem and we'll try to implement a similar fix on our side.
And we'll try to have a fix for this in the next Oxygen 20.0 minor bug fix release (in 3-4 weeks).
In the meantime maybe you could try to have a common shared DITA OT distribution (copied from the one inside Oxygen) and in the Oxygen Preferences->DITA page refer to this custom DITA OT distribution instead of referring to the DITA OT 2.x bundled with Oxygen.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Costin
Posts: 701
Joined: Mon Dec 05, 2011 6:04 pm

Re: RTF transform seems incomplete

Post by Costin » Thu Apr 26, 2018 5:15 pm

Hello,

Just to update the thread, I wanted to let you know that this problem has been resolved in the latest maintenance build of Oxygen 20.0, 2018042410 (released today, April 26th):
DITA-OT Publishing: DITA to RTF publishing no longer worked.
You can download it from our web site:
http://www.oxygenxml.com/download.html

The list of bug-fixes can be found here:
http://www.oxygenxml.com/build_history.html#2018042410

You can follow the release/build RSS feed here:
http://www.oxygenxml.com/rssBuildID.xml

To upgrade:
- For Windows and Linux you can install the new build in the same folder as the previous installation, it will automatically upgrade it.
Before you upgrade, if you have added files or made changes to any of the files from the Oxygen installation folder(especially the frameworks folder), you may want to create a backup of them because they will be overwritten during the upgrade procedure. Custom frameworks will be preserved but we recommend backing them up anyway, just to be safe.
- For Mac OS X you will have to either move the old folder from Applications to a different location and put the new version of Oxygen in its place, or install in a different folder. You can then copy any files you may have changed from the old folder (if any) to the new folder.

The Oxygen preferences will be preserved since they are located elsewhere (user home folder).

Let us know if you encounter further problems with this new build.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support

Post Reply