Reuse not working with WebHelp in Oxygen 19

ann.jensen
Posts: 226

Reuse not working with WebHelp in Oxygen 19

Fri Apr 14, 2017 11:52 am

Hi,
My Oxygen XML Author project uses topic reuse across ditamaps using keyscopes.
This project transforms fine with Oxygen 18.1 but I now having problems when I transform using WebHelp in Oxygen 19.

For the 3 uses of a topic called c_prop_summary_ags.dita the WebHelp transform in Oxygen 18.1 generates 3 files i.e.
- c_prop_summary_ags.html
- c_prop_summary_ags-1.html
- c_prop_summary_ags-2.html.

For the same 3 uses of that file, WebHelp transform in Oxygen 19 generates only 1 file i.e. c_prop_summary_ags.html and so links to prop_summary_ags-1.html and c_prop_summary_ags-2.html do not work.

How does WebHelp transform in Oxygen 19 handle topic reuse with keyscopes?
Thanks in advance,
Ann
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri Apr 14, 2017 11:56 am

Hi Ann,

Oxygen 19 comes bundled with DITA OT 2.4.4 so possibly this change in publishing engine is to blame.
Do you have the same problem when publishing to plain XHTML?
Could you send us a sample DITA project to reproduce the problem on our side?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri Apr 14, 2017 4:35 pm

Hi,

Just to update this thread, adding link to the DITA OT issue I added:

https://github.com/dita-ot/dita-ot/issues/2659

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
ionela
Posts: 218

Re: Reuse not working with WebHelp in Oxygen 19

Tue Apr 25, 2017 2:36 pm

Hello,

This problem has been resolved in the latest maintenance build of Oxygen 19.0, 2017042020 (released on April 24th):
DITA-OT: Fixed DITA Open Toolkit 2.x problem with properly generating HTML topics when using branch filtering.

You can download it from our web site:
http://www.oxygenxml.com/download.html

The list of bug-fixes can be found here:
http://www.oxygenxml.com/build_history.html#2017042020

You can follow the release/build RSS feed here:
http://www.oxygenxml.com/rssBuildID.xml

Let us know if you encounter further problems with this new build.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Tue Apr 25, 2017 3:58 pm

Hi,
I have downloaded the maintenance build and tested.
The previous issues relating to reuse with branch filtering seem to be resolved with this build.
Thanks and regards,
Ann
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 19, 2017 3:12 pm

Hi, our automation department has installed Oxygen WebHelp V19.0 build 2017042020 on their server and have transformed our DITA project.
My reuse strategy (keyscopes with keyrefs) doesn't seem to be working the generated webhelp. It works fine locally.
I have compared the output from my local transform and the server transform and have extracted the following for one of my reused topics i.e. c_tab_menu_display.dita.

INSTANCES OF c_tab_menu_display-1. IN MY LOCAL BUILD
_________________________________________________________

Code: Select all

REMOVED PER USER REQUEST




INSTANCES OF c_tab_menu_display-1. IN SERVER BUILD
_________________________________________________________

Code: Select all

REMOVED PER USER REQUEST



Does this shine any light on what might be happening differently in our server build?
Any advice appreciated,
Regards,
Ann
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 19, 2017 4:28 pm

Hi Ann,

How exactly is the WebHelp publishing set up on the server? Did you copy on it exactly the same DITA OT which was bundled with Oxygen 19.0?
If not, what DITA OT 2.x version do you have on the server?
Do you run the WebHelp publishing there using the "dita" command or the command line executables we distribute in the WebHelp plugin?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 19, 2017 4:44 pm

Hi Radu,
We have been running the webhelp transformation on our build server for the last 6 months but only just upgraded to V19 of webhelp.
I have also configured the same locally on my machine so that I can do a command line transformation so the following are true for the server and my local configuration (outside of Oxygen XML Author).

How exactly is the WebHelp publishing set up on the server? Did you copy on it exactly the same DITA OT which was bundled with Oxygen 19.0?

We upgraded the build server from DITA 2.2 to DITA 2.4.4 and upgraded from Oxygen WebHelp V18.1 to the latest Oxygen WebHelp V19 (build 2017042020).

Do you run the WebHelp publishing there using the "dita" command or the command line executables we distribute in the WebHelp plugin?

The transformation command locally is

Code: Select all

dita.bat -v -i "C:\DevBranches\DocService_devel\AGS_Documentation\supermap_AGS.ditamap" -f "webhelp-responsive" -filter "C:\DevBranches\DocService_devel\AGS_Documentation\ditavals\m_ags_filter.ditaval" -o "C:\DevBranches\DocService_devel\AGS_Documentation\out\webhelp-responsiveCMD" -propertyfile "webhelp.properties"


WebHelp.Properties contains the following:

Code: Select all

webhelp.responsive.template.name=ags_bootstrap
webhelp.responsive.variant.name=tiles
webhelp.responsive.skin.name=ags_bootstrap_tiles
clean.output=yes
args.breadcrumbs=yes
args.copycss=No
webhelp.logo.image=C:/DevBranches/DocService_devel/AGS_Documentation/------iDocs.png
webhelp.top.menu.depth=3
webhelp.show.side.toc=no
webhelp.show.main.page.tiles=yes
webhelp.show.top.menu=yes
conserve-memory=true
args.grammar.cache=no
generate-debug-attributes=false
webhelp.reload.stylesheet=true
webhelp.fragment.footer=C:/DevBranches/DocService_devel/AGS_Documentation/footer.xml
webhelp.fragment.head=C:/DevBranches/DocService_devel/AGS_Documentation/googleAnalytics_QA.html
webhelp.fragment.welcome=Easy to use. Quick to implement.
webhelp.show.child.links=yes
baseJVMArgLine=-Xmx4000m


Regards,
Ann
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 19, 2017 4:54 pm

Hi Ann,

I would suggest that you get the latest DITA OT 2.4.6 for your server:

http://www.dita-ot.org/download

Oxygen's bundled DITA OT is 2.4.4 but it has some extra patches in it, some of the patches are incorporated directly in 2.4.6.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 26, 2017 11:09 am

Hi Ann,

Sorry for wasting your time, I was under the impression that the issue I added for your problem:

https://github.com/dita-ot/dita-ot/issues/2659

had a fix for it included in DITA OT 2.4.6 but it did not, the issue is fixed but it will probably be available in DITA OT 2.4.5.
In the meantime, there is a patches library inside the DITA OT 2.x bundled with Oxygen 19.0:

OXYGEN_INSTALL_DIR\frameworks\dita\DITA-OT2.x\lib\dost-patches.jar

You can copy it to the equivalent "lib" folder for your custom DITA OT distribution, then modify the script file dita-ot-2.4.6\resources\env.bat and add at the beginning of it a reference to this new library:

set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\lib\dost-patches.jar"

If you are running on Linux you should do the same thing with the "env.sh" Linux script equivalent.
After this, the various patches we make for the DITA OT should be taken into account, including this filtering problem.
Ideally you would downgrade the external DITA OT to version 2.4.4 as our patches were created for 2.4.4 and we cannot guarantee they work with 2.4.6 although from what I tested this particular patch seemed to also work work 2.4.6.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 26, 2017 1:58 pm

Hi Radu,

I have tried your suggestions with both DITA OT 2.4.4 and DITA OT 2.4.6 but the branch filtering issue persists.

For each DITA OT I did the following:
1. Copied dost-patches.jar from my install of Oxygen XML Author 19.0 build 2017042020 and pasted it into <DITA OT INSTALL>\lib folder.
2. Updated env.bat in <DITA OT INSTALL>\resources folder and added the following as the first line in the file:

Code: Select all

set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\lib\dost-patches.jar"

3. Opened a command prompt by running startcmd.bat from <DITA OT INSTALL>\ folder.
4. Navigated to bin folder and ran the following command

Code: Select all

dita.bat -v -i "C:\DevBranches\DocService_devel\Oxygen_samples\reuse_issue_full\working\AGS_Documentation\supermap_AGS.ditamap" -f "webhelp-responsive" -o "C:\DevBranches\DocService_devel\Oxygen_samples\reuse_issue_full\working\out"


Am I doing something wrong?
Thanks,
Ann
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 26, 2017 2:05 pm

Hi Ann,

I will try to find some time to test again, let's try to focus only on the DITA OT 2.4.4 distribution for now. Out of curiosity can you also try to publish to plain xhtml -f "xhtml" to another output folder and see if the TOC properly points to the existing topic in both cases?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 26, 2017 2:13 pm

Hi Radu,
The same problem exists for me when transforming using xhtml.
Regards,
Ann
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Fri May 26, 2017 4:06 pm

Hi Ann,

I double checked, downloaded a fresh DITA OT 2.4.4, installed in it the WebHelp plugin, copied the "dost-patches.jar" to dita-ot-2.4.4\lib, modified the dita-ot-2.4.4\resources\env.bat so that it looks like this:

Code: Select all

set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\lib\dost-patches.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\com.oxygenxml.webhelp\lib\ant-contrib-1.0b3.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\com.oxygenxml.highlight\lib\xslthl-2.1.1.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2\lib\fo.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.axf\lib\axf.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\avalon-framework-api-4.3.1.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\avalon-framework-impl-4.3.1.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-anim-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-awt-util-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-bridge-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-css-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-dom-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-ext-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-extension-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-gvt-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-parser-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-script-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-svg-dom-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-svggen-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-transcoder-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-util-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\batik-xml-1.8.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\commons-logging-1.0.4.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\fop-2.1.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\xmlgraphics-commons-2.1.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.fop\lib\xml-apis-ext-1.3.04.jar"
set "CLASSPATH=%CLASSPATH%;%DITA_HOME%\plugins\org.dita.pdf2.xep\lib\xep.jar"


then started the command line, generated WebHelp Responsive and it works for me, I have both c_dashboard-1.html and c_dashboard.html present, with different images referenced and properly referenced from the TOC.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Mon May 29, 2017 2:03 pm

Hi Radu,
I don't know what we are doing different to you as I have tested on my machine and a colleague's and we are having the same problem i.e. there is no second html file generated for the reuse of dashboard.dita.

1. Downloaded fresh DITA OT 2.4.4
2. Downloaded fresh Oxygen WebHelp 19.0 and copied into DITA OT 2.4.4/plugins
3. Opened command prompt via C:\DITA\dita-ot-2.4.4\startcmd.bat and ran ant -f integrator.xml (this changes contents of env.bat)
3. Copied over dost-patches.jar from my install of Oxygen XML Author (\Oxygen XML Author 19_1\frameworks\dita\DITA-OT2.x\lib) to C:\DITA\dita-ot-2.4.4\lib
4. Updated C:\DITA\dita-ot-2.4.4\resources\env.bat to reference dost/patches.jar (on first line of env.bat)
5. Opened command prompt via C:\DITA\dita-ot-2.4.4\startcmd.bat and ran my transformation command i.e.

Code: Select all

dita.bat -v -i "C:\DevBranches\DocService_devel\Oxygen_samples\reuse_issue_full\working\AGS_Documentation\supermap_AGS.ditamap" -f "xhtml" -o "C:\DevBranches\DocService_devel\Oxygen_samples\reuse_issue_full\working\out"


The same problem exists whether I transform to xhtml or webhelp-responsive.
Regards,
Ann
Radu
Posts: 5760

Re: Reuse not working with WebHelp in Oxygen 19

Mon May 29, 2017 2:50 pm

Hi Ann,

The only thing I did differently was on step (5), if you are using the "dita.bat" you no longer need to run the "startCMD.bat" and open that new console because the "dita.bat" takes care by itself of the entire classpath setup. So you may want to avoid running the "startCMD.bat" which is the old way of setting up the publishing environment. Or at least edit the "startCMD.bat", it also has a classpath list with a bunch of JAR libraries, add a reference to the "dost-patches.jar" again very early in the list, as the first referenced JAR.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
ann.jensen
Posts: 226

Re: Reuse not working with WebHelp in Oxygen 19

Mon May 29, 2017 2:59 pm

Hi Radu,
That's it. When I open the command prompt without using startcmd.bat, the transformation works and the extra html file is generated :D :D :D
Thanks for all your help,
Regards,
Ann

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 1 guest