Prev and Next links disappear after Search

smitchell
Posts: 4

Prev and Next links disappear after Search

Tue Nov 25, 2014 11:17 pm

We are just starting to try the WebHelp transformation with a <set> of books and so I'm playing with things trying to figure out what we need to customize (mainly CSS). I have noticed one behavior and am not sure if this is a bug or not.

1. Run the transform and open this in a browser (I'm using FireFox on Windows 8). Most of the topics have Next | Prev buttons in the navigationlinks <div> and they work fine.
2. Search for something and click the link to a result --> this displays but the Next and Prev links are not visible. Moreover, the links remain hidden even if I move back to the TOC tab and use the TOC to navigate. If I reload a page, they reappear.

I've looked at this in Firebug and don't see any difference in the CSS, so I'm thinking that this is an unexpected affect of some of the JavaScript from Search.

Is this a known bug? or is there a fix or workaround?
sorin_ristache
Posts: 4144

Re: Prev and Next links disappear after Search

Fri Nov 28, 2014 6:12 pm

Hi,

It is a bug which was introduced recently in the WebHelp transformation. We already identified the code area that sets the display:none to the Next and Previous links and we will fix it in the next several days. The fix will go in the next Oxygen 16.1 maintenance build. I can send you the fix by email once we have the problem fixed, if you want it before the next maintenance build.
Regards,
Sorin

<oXygen/> XML Editor Support
smitchell
Posts: 4

Re: Prev and Next links disappear after Search

Mon Dec 01, 2014 9:08 pm

That would help. I have a somewhat ignorant question as well. I'm working on 16.0, but the other writers in our group are on 15.x (not sure everyone is all on the same version). Am I right that they are not going to need this fix?

Thanks,
Sara
sorin_ristache
Posts: 4144

Re: Prev and Next links disappear after Search

Tue Dec 02, 2014 11:42 am

Hi Sara,

I just emailed you the file that you need to replace in your Oxygen install directory for fixing this problem in the WebHelp pages.
Regards,
Sorin

<oXygen/> XML Editor Support
smitchell
Posts: 4

Re: Prev and Next links disappear after Search

Fri Dec 05, 2014 10:52 pm

Sorin,

I'm getting weird results when I apply the patch in my environment. Specifically, the content pane (<iframe>) is not getting filled -- it's blank.

* I put the patch in C:\Program Files\Oxygen XML Editor 16\frameworks\docbook\xsl\com.oxygenxml.webhelp\oxygen-webhelp\resources\js. Is this the correct folder?

* Should this also be applied to the DITA framework? We have some content in DITA (in the process of moving over).

* I noticed the file name showed 16.1, but I'm still running 16.0. Is it possible this is causing the problem?

Thanks,
Sara
sorin_ristache
Posts: 4144

Re: Prev and Next links disappear after Search

Mon Dec 08, 2014 4:03 pm

Hello Sara,

I tried to implement the same change for version 16.0. I sent you the modified file by email.

Anyway this bug fix will be included in the next version of Oxygen.
Regards,
Sorin

<oXygen/> XML Editor Support
ionela
Posts: 141

Re: Prev and Next links disappear after Search

Tue Jan 27, 2015 9:49 pm

Hello,

Just to update the thread, this problem has been resolved in the latest maintenance build of Oxygen 16.1, 2015012213 (released on January 26th):
WebHelp: After searching and clicking on a search result the navigation links (Next/Previous Topic) no longer appeared.

You can download it from our web site:
http://www.oxygenxml.com/download.html

The list of bug-fixes can be found here:
http://www.oxygenxml.com/build_history.html#2015012213

You can follow the release/build RSS feed here:
http://www.oxygenxml.com/rssBuildID.xml

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Return to “DocBook”

Who is online

Users browsing this forum: No registered users and 0 guests