Spellcheck does not remember words with apostrophes

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
friedemann_bach
Posts: 48
Joined: Wed Oct 22, 2014 4:11 pm

Spellcheck does not remember words with apostrophes

Post by friedemann_bach » Wed Nov 12, 2014 8:02 pm

Dear Forum,

I frequently use Hunspell. As I work a lot on historical (German) texts, I have added a lot of words to my dictionary. Now I have trouble with words that contain apostrophes, for example: "Shakespeare’s" (with typographical apostrophe). After having added such a word to the dictionary, it is still being displayed as errors, again and again. I checked in the dictionary file (de.tdi), the words were added correctly. Is there a way to fix this?

Best regards
friedemann

adrian
Posts: 2666
Joined: Tue May 17, 2005 4:01 pm

Re: Spellcheck does not remember words with apostrophes

Post by adrian » Thu Nov 13, 2014 8:33 pm

Hi,

I've tested and the typographical apostrophe (U+2019) from the learned words seems to trigger an encoding problem in the .tdi file. I've logged this and I'm currently looking into possible workarounds.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Radu
Posts: 7094
Joined: Fri Jul 09, 2004 5:18 pm

Re: Spellcheck does not remember words with apostrophes

Post by Radu » Mon May 18, 2015 3:18 pm

Hi,

Just to update this post, the issue should be fixed in Oxygen 17.0.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply