v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
dnedrow
Posts: 60
Joined: Wed Jan 28, 2004 10:51 pm

v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Post by dnedrow » Thu May 01, 2008 6:23 pm

Virtually all of my Java applications run fine with the 64-bit versions of Java 5 and 6 under OS X (Leopard). Eclipse, however, won't launch and the following errors show in the system log...

Code: Select all


5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] [JavaAppLauncher] A 64-bit JVM is available for 1.5.0 
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] [JavaAppLauncher] JVMArchs not found in Java dictionary
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] Exception in thread "main"
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] java.lang.NoClassDefFoundError: ro/sync/util/l
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] at java.lang.Class.forName0(Native Method)
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] at java.lang.Class.forName(Class.java:242)
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:55)
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] at apple.launcher.LaunchRunner.run(LaunchRunner.java:111)
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
I've tried making changes to the info.plist as suggested in Apple Radar reports 5226690 and 5422774. Adding the JVMArchs to the oXygen plist corrected the missing jvmarchs error, but the app won't launch.

Here's the log output after making the changes noted above...

Java 5...

Code: Select all


5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] [JavaAppLauncher] A 64-bit JVM is available for 1.5.0 
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] Exception in thread "main" java.lang.NoClassDefFoundError: ro/sync/util/l
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] at java.lang.Class.forName0(Native Method)
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] at java.lang.Class.forName(Class.java:242)
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:55)
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] at apple.launcher.LaunchRunner.run(LaunchRunner.java:111)
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
5/1/08 11:25:05 AM [0x0-0x13a13a].ro.sync.exml.Oxygen[11318] at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Java 6...

Code: Select all


5/1/08 11:31:05 AM [0x0-0x13c13c].ro.sync.exml.Oxygen[11330] [JavaAppLauncher] A 64-bit JVM is available for 1.6.0 
5/1/08 11:31:05 AM [0x0-0x13c13c].ro.sync.exml.Oxygen[11330] [JavaAppLauncher] and it is the only version available
5/1/08 11:31:05 AM [0x0-0x13c13c].ro.sync.exml.Oxygen[11330] [JavaAppLauncher] Application wants to use 64-bit JVM
5/1/08 11:31:05 AM [0x0-0x13c13c].ro.sync.exml.Oxygen[11330] [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
5/1/08 11:31:05 AM [0x0-0x13c13c].ro.sync.exml.Oxygen[11330] Exception in thread "main"
5/1/08 11:31:05 AM [0x0-0x13c13c].ro.sync.exml.Oxygen[11330] java.lang.NoClassDefFoundError: ro/sync/util/l

Any idea what is going on? I'm guessing maybe there are native methods in oXygen that are 32-bit only. I still haven't figure out where to set the equivalent of the "-d32" flag for the oXygen package. I'm guessing that would work around the launch problem, but still doesn't resolve the root problem.

Should you need the VM info, here it is...

Java 6 64-bit....

java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13-120)
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_05-b13-52, mixed mode)

Java 5 64-bit...

java version "1.5.0_13"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05-237)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_13-119, mixed mode)

Radu
Posts: 7108
Joined: Fri Jul 09, 2004 5:18 pm

Re: v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Post by Radu » Fri May 02, 2008 10:05 am

Hello,

The Oxygen Eclipse plugin is pure Java and does not contain any native code in it.
Are you running the 64-bit Eclipse version with the 64-bit JVMs?
Eclipse uses native code and if the JVMs are 64 bit so should the Eclipse installation kit.

Can you try to remove the Oxygen plugin and restart Eclipse?
To remove it manually you must delete the "com.oxygenxml.editor" folders from the eclipse "plugins" and "features" directories.
Then run Eclipse using the "-clean" parameter.
Does it work this way?

Try then to reinstall Oxygen and run Eclipse using the "-clean" parameter.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

dnedrow
Posts: 60
Joined: Wed Jan 28, 2004 10:51 pm

Re: v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Post by dnedrow » Fri May 02, 2008 3:10 pm

Actually, the oXygen plugin is working fine in Eclipse (Eclipse is running in 32-bit mode).

The problem I'm having is the Eclipse standalone application which won't launch.

-David

dnedrow
Posts: 60
Joined: Wed Jan 28, 2004 10:51 pm

SOLVED: Re: v9.1 won't launch with 64-bit Java 6 or 5 on OS

Post by dnedrow » Fri May 02, 2008 3:32 pm

It looks as though something in my oXygen tree was missing or corrupt.

I re-extracted the archive and the contained oXygen ran fine, though with the missing archs error.

You may want to add the following recommended entries to the oXygen info.plist file. Doing so will clear an informational message from the logs...

Code: Select all


		<key>JVMArchs</key>
<array>
<string>x86_64</string>
<string>i386</string>
<string>ppc</string>
</array>

Radu
Posts: 7108
Joined: Fri Jul 09, 2004 5:18 pm

Re: v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Post by Radu » Fri May 02, 2008 3:45 pm

Dear David,

We did not realize that you were talking about the Oxygen standalone application.
It is a pure Java application that has nothing to do with the Eclipse platform in any way.

Thank you for the Info.plist hint.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply