XQuery docs shortcut associated with @ sign on GER keyboards

<oXygen/> general issues.
mf
Posts: 2
Joined: Thu Jun 14, 2007 2:32 pm
Location: Vienna (AUT)

XQuery docs shortcut associated with @ sign on GER keyboards

Post by mf » Thu Jun 14, 2007 2:43 pm

This is just to draw your attention to a minor annoyance with one of oXygen's default shortcuts.

On German keyboards, there's an "ALT Gr" key (the right ALT key), which corresponds to ALT+SHIFT. The "@" sign is accessed by ALT Gr+Q on such keyboards, which is in conflict with one of oXygen's default shortcuts: the ALT+SHIFT+Q access key for the XQuery Docs. Given the frequent use of the @ sign, any user working with a German keyboard will have to change or remove this shortcut.

As I said, a minor thing indeed, but I wanted to bring it to your attention.

btw: great product, keep up the good work!

Markus

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: XQuery docs shortcut associated with @ sign on GER keybo

Post by sorin_ristache » Fri Jun 15, 2007 12:17 pm

Hello,
mf wrote:which is in conflict with one of oXygen's default shortcuts: the ALT+SHIFT+Q access key for the XQuery Docs.
The default shortcut for the XQuery Documentation action is CTRL+ALT+Q, not ALT+SHIFT+Q. Did you redefine the shortcut of the XQuery Documentation action in Options -> Preferences -> Menu Shortcut Keys?


Regards,
Sorin

mf
Posts: 2
Joined: Thu Jun 14, 2007 2:32 pm
Location: Vienna (AUT)

Post by mf » Fri Jun 15, 2007 12:50 pm

sorry about the mixup. "Alt Gr" _is_ "CTRL+ALT" on GER Windows keyboards.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Post by sorin_ristache » Fri Jun 15, 2007 3:12 pm

Yes, with a German keyboard the character @ is inserted in the text editor. We changed the default shortcut to Ctrl+Shift+Q which is not associated to other action and which does not insert a character in the text editor. It is a default shortcut which means for existing oXygen users it is set only on the Reset Global Options action. So as an existing user you have to change the shortcut either by executing the Reset Global Options action or by going to Options -> Preferences -> Menu Shortcut Keys and changing the shortcut.


Regards,
Sorin

Post Reply