Git integration fails

Post here questions and problems related to editing and publishing DITA content.
ssanjeeva
Posts: 1
Joined: Fri Nov 24, 2023 5:43 pm

Git integration fails

Post by ssanjeeva »

Hi,
I am reaching out to seek assistance regarding an issue I am encountering with the Git integration for our Bitbucket repository.
I have made several attempts to establish connections using both HTTPS and SSL protocols, but unfortunately, I have encountered persistent failures. For your reference, I have attached a screenshot illustrating the error message.
In my troubleshooting efforts, I have explored different authentication methods, including Personal Access tokens and Basic authentication. Additionally, I have generated an SSH key and successfully added it to my Bitbucket account.
Here are the specifics of my environment:
  • Operating System: Windows 10 Enterprise
  • <oXygen/> XML Editor: Version 23.1, build 2021121415
I am reaching out to seek your expertise in identifying the root cause of this issue and providing guidance on a resolution. Kindly help.

Please let me know if you require any additional information or if there are specific steps I should follow to assist you in diagnosing and resolving this matter.
git_erroe.png
git_erroe.png (57.82 KiB) Viewed 323 times
alex_jitianu
Posts: 1007
Joined: Wed Nov 16, 2005 11:11 am

Re: Git integration fails

Post by alex_jitianu »

Hi,

I'm sorry for the inconvenience. What Git Client version are you using? Judging from the oxygen version you are probably running Git Client version, 4.0.2.

From the screenshot I don't actually see the error message, just the dialog requesting for credentials. Bitbucket uses a concept similar to personal access tokens, named app passwords. An app password must be provided as the password for Basic authentication, along with the correct username. Did you tried it like that? Specifying both the user name and the app password?

If it still doesn't work, the error message is displayed in the Staging view, on the button. You'll have to hover it to get the actual error message displayed. You can also try to start Oxygen using the oxygen.bat launcher. Try to connect to the repository then look inside the console for any error messages or exceptions.
If still no luck, please write us on support@oxygenxml.com and I will send instructions on how to activate the logging so we can better understand the cause.

Best regards,
Alex
Post Reply