Changing oXygen versions made my WH transformation laggy

Post here questions and problems related to editing and publishing DITA content.
La_Gej
Posts: 11
Joined: Fri Apr 01, 2022 3:52 pm

Changing oXygen versions made my WH transformation laggy

Post by La_Gej »

Hello
Since Monday the 13th, I've switched PCs and updated oXygen from version 22.0 to version 24.1. When I launched a WH Responsive transformation from my new PC, some weird stuff happened :
  • Publication and Topic TOC closing buttons appeared (I simply put a display:none in my custom CSS to stop them from appearing as I couldn't find anything in the transformation parameters),
  • The "wh_tools" line became sticky, as a new class, ".breadcrumb-sticky" was applied (I fought it back in my custom CSS),
  • And most importantly, my dropdown-menu became very laggy. Menus will take a few seconds to appear when hovered on, and when the mouse goes away, the background box will disappear immediately but not the text, which will take some more time to disappear. It can take so much time to disappear that the text will overlap.
    dropdown.png
    dropdown.png (33.72 KiB) Viewed 321 times
I don't know what could change such things to my output, as all the files are exactly the same as previously.
If anyone has an idea, I'm all ears.
Costin
Posts: 777
Joined: Mon Dec 05, 2011 6:04 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by Costin »

Hi La_Gej,

First, you should please make sure that you follow the template conversion procedures, to switch older templates to the latest version.
Depending on the version used to create the template, you should follow the appropriate procedures from the Converting Old Templates To Newer Versions section from the WebHelp User-Guide in sequential order.
More specific, as you mentioned you used version 22 before, to be able to use the template with the latest version 24.1 of Oxygen XML WebHelp, you should first follow all of the below procedures sequentially:
- Convert Version 22 Publishing Templates to Version 23
- Convert Version 23 Publishing Templates to Version 24
- Convert Version 24.0 Publishing Templates to Version 24.1

Let us know if you still encounter issues after you followed the procedures.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support
La_Gej
Posts: 11
Joined: Fri Apr 01, 2022 3:52 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by La_Gej »

Thanks for your response Costin.
The thing is that for me to be able to convert my template, I need to have a page_template folder and a template_descriptor file, but I have none of these. So far, I've done all my transformations simply by using a basic template.opt file and a custom CSS, as I'm new to DITA and didn't know they were other transformation customization options. I feel both dumb and stuck
La_Gej
Posts: 11
Joined: Fri Apr 01, 2022 3:52 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by La_Gej »

So I've found the missing files (I simply forgot to tick a box when exporting my transformation settings), and I've migrated them to the latest version but the issue is still here...
chrispitude
Posts: 529
Joined: Thu May 02, 2019 2:32 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by chrispitude »

Hi La_Gej,

Does a default (uncustomized) WebHelp transformation produce the laggy menus?

If so, then you could progressively remove your customizations to get back to a default transformation, and see which removal corrects the issue. (Or, you could go the other way and progressively add them to a default transformation.)
La_Gej
Posts: 11
Joined: Fri Apr 01, 2022 3:52 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by La_Gej »

Hi Chris, sorry for the late answer - yes, a default transformation will still produce laggy menus.
Costin
Posts: 777
Joined: Mon Dec 05, 2011 6:04 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by Costin »

Hi La_Gej,

Starting with version 24.1, in order to avoid unwanted display of menus, we implemented a short delay after hovering over the parent menu item, so this is intended behavior.
However, the menu has two different display modes - one is by hovering over a menu item, the other way is to click the parent menu item.
There is a dedicated parameter that enables the display of the menu by clicking the parent menu item. Just set the "webhelp.top.menu.activated.on.click" to "yes". The submenus should be displayed immediately after clicking the parent menu item.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support
La_Gej
Posts: 11
Joined: Fri Apr 01, 2022 3:52 pm

Re: Changing oXygen versions made my WH transformation laggy

Post by La_Gej »

Thanks Costin !
I guess there's no hovering issue when hovering is disabled :lol:
Post Reply