© in my webhelp footer display

Are you missing a feature? Request its implementation here.
bill
Posts: 13
Joined: Tue May 17, 2022 5:56 am

© in my webhelp footer display

Post by bill »

I use the webhelp.fragment.footer parameter to change the footer to xxx © xxx, but the symbol display ? instead like the picture below. How can I correct it?
image.png
image.png (1.62 KiB) Viewed 172 times
bill
Posts: 13
Joined: Tue May 17, 2022 5:56 am

Re: © in my webhelp footer display

Post by bill »

Can anyone tell me how to do with this problem? I look forward for your answer.
beniamin_savu
Posts: 8
Joined: Fri Jan 22, 2021 11:05 am

Re: © in my webhelp footer display

Post by beniamin_savu »

Hi,

Using WebHelp version 24.1 we did not manage to reproduce your problem.

We created an HTML file and set the webhelp.fragment.footer parameter value to the path of this HTML file. The HTML file contains the following code snippet:

Code: Select all

<div>Test xxx © xxx. Another test xxx &copy; xxx</div>
After running the WebHelp Responsive transformation the symbol was displayed correctly in the browser:
image.png
image.png (2.77 KiB) Viewed 116 times

Could you please tell us what version of WebHelp are you using? Are you using a custom publishing template? If you are using a custom publishing template could you run the WebHelp Responsive transformation with one of the default templates and let us know if the problem still persists?

Best regards,
Beniamin Savu
Oxygen WebHelp Team
http://www.oxygenxml.com
bill
Posts: 13
Joined: Tue May 17, 2022 5:56 am

Re: © in my webhelp footer display

Post by bill »

Can you show me the HTML file you are using? I have no example of this file.
bill
Posts: 13
Joined: Tue May 17, 2022 5:56 am

Re: © in my webhelp footer display

Post by bill »

beniamin_savu wrote: Tue May 24, 2022 4:50 pm Hi,

Using WebHelp version 24.1 we did not manage to reproduce your problem.

We created an HTML file and set the webhelp.fragment.footer parameter value to the path of this HTML file. The HTML file contains the following code snippet:

Code: Select all

<div>Test xxx © xxx. Another test xxx &copy; xxx</div>
After running the WebHelp Responsive transformation the symbol was displayed correctly in the browser:
image.png


Could you please tell us what version of WebHelp are you using? Are you using a custom publishing template? If you are using a custom publishing template could you run the WebHelp Responsive transformation with one of the default templates and let us know if the problem still persists?

Best regards,
Beniamin Savu
Oxygen WebHelp Team
http://www.oxygenxml.com
Hi,
Thanks for your answer.
Can you show me the HTML file you are using? I have no example of this file.
beniamin_savu
Posts: 8
Joined: Fri Jan 22, 2021 11:05 am

Re: © in my webhelp footer display

Post by beniamin_savu »

Hi,

I created a small publishing template that adds a custom footer:
CustomFooter.zip
(8.61 KiB) Downloaded 5 times

Could you run the WebHelp Responsive transformation using this publishing template and tell us if the © symbol is displayed in the transformation output? The HTML file used to display the custom footer is in ${publishingTemplateFolder}/html-fragments/footer.html

More information about the publishing template can be found using the following link: https://www.oxygenxml.com/doc/versions/ ... plate.html
More information about how to add HTML content to your WebHelp output can be found using the following link: https://www.oxygenxml.com/doc/versions/ ... -html.html

Best regards,
Beniamin Savu
Oxygen WebHelp Team
http://www.oxygenxml.com
Last edited by beniamin_savu on Wed May 25, 2022 5:23 pm, edited 1 time in total.
Post Reply