Don't want my SVG diagram in an image modal

toolie
Posts: 25
Joined: Thu Jan 29, 2015 2:40 am

Don't want my SVG diagram in an image modal

Post by toolie » Mon May 10, 2021 7:33 am

Hi there, I'm working with a complex SVG file in which I need to put over a dozen hyperlinks. I know how to do that properly within the SVG, but when I transform the doc set to webhelp-responsive, the SVG image ends up in a modal preview, and the hotspots disappear. I do NOT want to use an image map -- that will take FOREVER to set up.

I have scaled down the SVG so that it fits within the width of the page. How can I get my SVG diagram to appear:
  • Inline with the HTML
  • NOT in a modal preview
  • Have the hyperlinks work?
Please advise, and thank you!
Toolie Garner

Costin
Posts: 734
Joined: Mon Dec 05, 2011 6:04 pm

Re: Don't want my SVG diagram in an image modal

Post by Costin » Tue May 11, 2021 12:38 pm

Hi toolie,

There is a dedicated parameter which is used to present images displayed at a smaller dimension than the original size in a modal preview.
The parameter is called "webhelp.show.full.size.image", so you could set it to "no" in the parameters tab of the WebHelp Responsive transformation scenario to avoid this.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support

toolie
Posts: 25
Joined: Thu Jan 29, 2015 2:40 am

Re: Don't want my SVG diagram in an image modal

Post by toolie » Mon May 24, 2021 2:35 am

Thank you for your response Costin. I changed the parameter as described, and now I don't get the lightbox, BUT there is still a hover effect that's preventing me from accessing the inserted hyperlinks in the SVG file.

How do I disable that hover effect?

Toolie
Toolie Garner

alin
Site Admin
Posts: 201
Joined: Thu Dec 24, 2009 11:21 am

Re: Don't want my SVG diagram in an image modal

Post by alin » Tue May 25, 2021 12:20 am

Hello,

You can try to use the following custom CSS rules to disable the unwanted hover effect:

Code: Select all

img.image:not(img[usemap]) {
    cursor: initial;
}

img.image:not(img[usemap]):hover {
    opacity: initial;
}
I have registered an issue to correct this behavior.

Regards,
Alin
Alin Balasa
Software Developer
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply