Problems with "parent" topics

<oXygen/> general issues.
sdarnowsky
Posts: 3
Joined: Wed Apr 14, 2021 8:47 pm

Problems with "parent" topics

Post by sdarnowsky » Wed Apr 14, 2021 9:03 pm

We currently have "parent" XML topics that reference "child" topics. (When you open the parent topic, you see all the content of all the children.) In oXygen 18, when we updated a child topic and then switched to the parent topic tab, the parent topic automatically displayed all the changes that were made to all the children. Now that we've upgraded to oXygen 23, we're no longer seeing that behavior. It's necessary to manually click Reload for the parent topic to view the changes to the child topics. Is there a setting somewhere that didn't get ported when we upgraded?

Another problem that I've noticed is that when I have a parent topic open and use the Find/Replace dialog box to find all instances of text (that is, I type a string in the Find box and click Find All), double-clicking an item in the Results panel opens the associated child topic and highlights the specified string. However, when I click Find All Elements on the Find/Replace dialog, type an element name (such as table), and then click Find All, double-clicking an item in the Results panel opens the associated topic, but the cursor position on the page seems to be random. It might be in the table; it might not. As a result, I can’t rely on the search capability to specifically find the element that I want to look at. I have to manually scroll the topic to find what I’m looking for. I’m pretty sure this was not a problem in 18, but I'm less certain of that.

Any suggestions for addressing these issues would be most welcomed!

IrinaNadolu
Posts: 10
Joined: Wed Mar 03, 2021 1:37 pm

Re: Problems with "parent" topics

Post by IrinaNadolu » Thu Apr 15, 2021 12:53 pm

Hello,

As I understand, your "parent" topic has several conrefs to other "child" topics. I tested on Oxygen 23.0, build 2020121712 and if I modify then save a "child" topic, and then switch to the "parent" file tab, the topic is updated with the content from the modified child. I don't need to use the Reload action, the "parent" content is updated instantly.

For the second problem, I tried the following: I opened the Find/Replace dialog in the "parent" topic, I typed some text in the Find area and clicked Find All. Some results were displayed in the Results view, I chose one of them and double clicked it and in the "parent" topic the specified string was highlighted; clicking a result from the Results view did not open the associated "child" topic in the Editor. Also, when using 'Find All Elements' there is a problem which will be solved on the next Oxygen version- 'Find All Elements' does not work on conreffed content.

I think it might help me if you could give me a few more details about the problem, maybe you could write at "support@oxygenxml.com" and send me some sample files. Once I’ve got that information from you, I can take a closer look.

Best regards,
Irina Nadolu
Irina Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

sdarnowsky
Posts: 3
Joined: Wed Apr 14, 2021 8:47 pm

Re: Problems with "parent" topics

Post by sdarnowsky » Thu Apr 15, 2021 5:08 pm

Thanks for the quick response! One of my colleagues, Melanie Petersman, also posted about the problem with the parent topic not updating automatically when the child topic is modified, and received a reply from you. She's going to supply you with some files to demonstrate the problem. She has both 18 and 23 installed on two separate machines. The updates occur automatically with one instance of 18, but not the other. (They are different builds of 18.) The automatic updates don't occur with either installation of 23, which is what my entire team uses. She's in a better position to discuss all this with you, so I'll just ask her to keep me posted on what you two might discover.

I look forward to the Find All Elements problem being fixed in an upcoming version. Will that just be in a new build of 23, or the next full release of the product?

Again, thank you for all your help!

IrinaNadolu
Posts: 10
Joined: Wed Mar 03, 2021 1:37 pm

Re: Problems with "parent" topics

Post by IrinaNadolu » Fri Apr 16, 2021 9:37 am

Hi,

The 'Find All Elements' problem is scheduled to be fixed in the Oxygen 24 version. As soon as it is fixed, we'll update this thread.

Thank you.

Best regards,
Irina Nadolu
Irina Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

sdarnowsky
Posts: 3
Joined: Wed Apr 14, 2021 8:47 pm

Re: Problems with "parent" topics

Post by sdarnowsky » Mon Apr 19, 2021 6:29 pm

Thanks for letting me know! Our company doesn't always upgrade with each version because of the amount of testing, etc., that needs to be done before they roll it out company-wide. (We went from 18 to 23, skipping everything in between.) But I hope they will upgrade to 24 for this fix, as it is valuable for our writers!

Post Reply