DITA OT 3.x Plugin installation - ant command fail

msambasiva
Posts: 83
Joined: Tue Jul 17, 2018 6:57 am

DITA OT 3.x Plugin installation - ant command fail

Post by msambasiva » Mon Mar 29, 2021 9:18 am

HI,

Created and installed a dita -ot plugin manually at below path
C:\dita\dita-ot-3.5\plugins\my.dita.plugin

Able to execute the bin\dita command sucessfully
bin\dita --format=mydita -Dmy.release=21a --input=/dev/null -Dargs.input.dir=C:\my\21a\input --output=C:\my\21a\output -Dmy.type=F --temp=C:\my\21a\temp -Dclean.temp='n'

But some how, below ant command got failed,
bin\ant -Dtranstype=mydita -Dargs.input.dir="C:\my\21a\input" -Doutput.dir="C:\my\21a\out" -Dmy.type="F" -Dclean.temp="n" -Dtemp

Buildfile: C:\dita-ot\dita-ot-3.5\build.xml
[loadproperties] Unable to find resource application.properties

BUILD FAILED
C:\dita-ot\dita-ot-3.5\build.xml:19: The following error occurred while executing this line:
C:\dita-ot\dita-ot-3.5\plugins\org.dita.base\build.xml:36: The following error occurred while executing this line:
C:\dita-ot\dita-ot-3.5\plugins\org.dita.base\build_init.xml:22: taskdef class org.dita.dost.ant.InitializeProjectTask cannot be found
using the classloader AntClassLoader[]

Total time: 0 seconds

The ant command got success in dita-ot-2.4.6.
WHen we install a plugin, it automatically updates dita-ot-2.4.6\build.xml with plugin details. But it's not the case in dita-ot.3.x.

It would be great help, if you can suggest any clue.

Thanks,
Samba.

Radu
Posts: 7538
Joined: Fri Jul 09, 2004 5:18 pm

Re: DITA OT 3.x Plugin installation - ant command fail

Post by Radu » Mon Mar 29, 2021 9:47 am

Hi Samba,

My advice to you is to switch to using the "dita" command for publishing instead of running ANT directly.
Otherwise you probably need to run this "startcmd.bat" script to set up these environmental variables before running ANT: "C:\dita\dita-ot-3.5\startcmd.bat"

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

msambasiva
Posts: 83
Joined: Tue Jul 17, 2018 6:57 am

Re: DITA OT 3.x Plugin installation - ant command fail

Post by msambasiva » Mon Mar 29, 2021 10:29 am

Thanks Radu! The issue got fixed with setting ANT_HOME env variable with proper DITA-OT directory.

Post Reply