DITA WebHelp Classic - Window title display topic title as undefined

Alf-lgmd
Posts: 1
Joined: Wed Feb 10, 2021 4:56 pm

DITA WebHelp Classic - Window title display topic title as undefined

Post by Alf-lgmd » Wed Feb 10, 2021 5:32 pm

Hello,
i have an issue with publishing a ditamap to WebHelp Classic, when displayed in Firefox,
the window title is showing "{correct ditamap title} - undefined"
The "undefined" should be the active selected topic title text.

Cornered the cause in toc_driver.js, with code that rewrites the page title

Code: Select all

$("title").html($("title").attr("title") + " - " + $("#frm").contents().find("title").html());
This appears to be only a Firefox issue,
in Chrome and Edge it displays only the ditamap title part; no " - {anything}" after, which is not so correct,
and eventually in "old" Internet Explorer, it works as it should with the display of "{ditamap title} - {topic title}"!

My guess would be the latest restriction in browser, on script prevented access to frame content!?
Or am i missing something else, as i am surprised that i didn't find any report of this obvious buggy display, overhere... or maybe not so much people publish to Webhelp Classic, and/or view result on Firefox ^^)


Thanks for your attention,
Fabrice

ionela
Posts: 353
Joined: Mon Dec 05, 2011 6:08 pm

Re: DITA WebHelp Classic - Window title display topic title as undefined

Post by ionela » Thu Feb 11, 2021 2:05 pm

Hi,

Thank you for your feedback and for letting us know about this issue.

Unfortunately, the WebHelp Classic scenario is deprecated and it won't be further improved.
But, the license allows you to implement the fix on your side and modify the WebHelp Classic sources.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Post Reply