Oxygen XML Editor not recognizing Condition Sets

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
zoelawson17
Posts: 3
Joined: Mon Apr 22, 2019 10:41 pm

Oxygen XML Editor not recognizing Condition Sets

Post by zoelawson17 » Mon Feb 03, 2020 6:40 pm

Greetings!

I'm on <oXygen/> XML Editor 21.1, build 2019120214.

I've gone into Profiling settings and imported sets of conditions from ditavals.

When I go into the profiling menu, it displays <No Profiling Condition Set is defined>.

But when I go into the Profiling Settings, there are two condition sets defined.

I've deleted all my profiling settings and reimported from ditavals, no change.
I rebooted my computer, and no change.

I can work around this, but having my otherprop values validated really, really helps.

Thanks,
Zoë

Radu
Posts: 6981
Joined: Fri Jul 09, 2004 5:18 pm

Re: Oxygen XML Editor not recognizing Condition Sets

Post by Radu » Tue Feb 04, 2020 11:36 am

Dear Zoë,

If you look in the Oxygen Preferences->"Editor / Edit Modes / Author / Profiling/Conditional Text" page at the "Profiling Condition Sets" table, each entry there has a "Document Type" value. By default that value is probably a pattern like "*DITA*". This pattern should match the document type name as it is configured in the "Document Type Association" page. So if you have a custom DITA document type/framework which does not include "DITA" in its name, then Oxygen will not match the defined profiling condition set with it.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

zoelawson17
Posts: 3
Joined: Mon Apr 22, 2019 10:41 pm

Re: Oxygen XML Editor not recognizing Condition Sets

Post by zoelawson17 » Wed May 27, 2020 6:31 pm

Thank you.
Sorry it took me so long to see this response.

I had the Document Type set to *DITA* for everything...and it didn't work.
I mucked around with the Document Type a few times, eventually setting it back to *DITA*...and everything started working. (And upgraded Oxygen once or twice, too)

I'm going to blame gremlins. Life is better now.

Zoë

Post Reply