xproc and xinclude with fixup-xml-base

<oXygen/> general issues.
ttasovac
Posts: 51
Joined: Fri Dec 19, 2003 6:02 pm

xproc and xinclude with fixup-xml-base

Post by ttasovac » Sun May 10, 2020 8:38 pm

I'm having trouble disabling the fixup-xml-base option in Xproc.

I have created an xproc transformation scenario in oXygen. In the Inputs, I defined a source port, and this port takes an XML doc which has a bunch of other fragments included with xi:include. The scenario also defines the final output on the result port.

The scenario works as expected with a number of xslt steps. But the first step — which is an <p:xinclude> doesn't seem to do what it should.

The xproc file with only the first step looks like this:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?> 
<p:declare-step xmlns:p="http://www.w3.org/ns/xproc" xmlns:c="http://www.w3.org/ns/xproc-step"
    version="1.0">
    
    <p:serialization port="result" method="xml" indent="true" omit-xml-declaration="false"/>
    <p:input port="source" sequence="true"/>
    <p:input port="parameters" kind="parameter"/>
    <p:output port="result" sequence="true"/>
 
    <p:xinclude fixup-xml-base="false" name="expand"/>
</p:declare-step> 
    
What this should do — unless I am missing something obvious — is take the document from the source (which is defined in the oXygen transformation), include all of its bits and spit it out on the result port, while disabling the xml:base fixup. This, however, doesn't happen. The document is output with a bunch of xml:bases in it.

I have two questions here:

1. Why is this not working as I think it should?
2. Shouldn't the oXygen general setting for the Base Uri fix-up take precedence here anyway? (I have it disabled, but it doesn't seem to have any effect on xproc pipelines.)

Many thanks in advance!

All best,
Toma

Radu
Posts: 7103
Joined: Fri Jul 09, 2004 5:18 pm

Re: xproc and xinclude with fixup-xml-base

Post by Radu » Mon May 11, 2020 9:57 am

Hi Toma,

From what I looked in our code, our own Oxygen "Base URI Fixup" setting should not interfere at all with what XProc does when processing content.
Now I'm not sure why this does not properly work with XProc, we have very little experience with using XProc. Can you try to maybe download XProc Calabash directly from it's website and see if you get the same problem when running it in a command line? If you do, maybe you can add an issue on the Calabash issues list, otherwise if you provide us with a complete set of small samples (XMLs + Xproc) we can continue the investigation on our side.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply