XSLT-Debugger crashes

Here should go questions about transforming XML with XSLT and FOP.
muewi
Posts: 26
Joined: Wed Aug 24, 2005 10:47 am

XSLT-Debugger crashes

Post by muewi » Fri May 26, 2006 10:17 am

Hi,

when trying to run the XSLT-Debugger, I get the error below.
I'm running Suse Linux 10.1 and oXygen 7.1.

Regards,
Frank

-------------------------------------------------------------------------------------------------------------------------
[ AWT-EventQueue-0 ] - java.lang.RuntimeException: Can't build aframeset, BranchElement(frameset) 1573,1577
:no ROWS or COLS defined.
java.lang.RuntimeException: Can't build aframeset, BranchElement(frameset) 1573,1577
:no ROWS or COLS defined.
at javax.swing.text.html.HTMLEditorKit$HTMLFactory.create(HTMLEditorKit.java:1105)
at javax.swing.text.CompositeView.loadChildren(CompositeView.java:95)
at javax.swing.text.CompositeView.setParent(CompositeView.java:122)
at javax.swing.text.html.BlockView.setParent(BlockView.java:55)
at javax.swing.text.html.HTMLEditorKit$HTMLFactory$BodyBlockView.setParent(HTMLEditorKit.java:1266)
at javax.swing.text.CompositeView.replace(CompositeView.java:200)
at javax.swing.text.BoxView.replace(BoxView.java:164)
at javax.swing.text.CompositeView.loadChildren(CompositeView.java:97)
at javax.swing.text.CompositeView.setParent(CompositeView.java:122)
at javax.swing.text.html.BlockView.setParent(BlockView.java:55)
at javax.swing.plaf.basic.BasicTextUI$RootView.setView(BasicTextUI.java:1214)
at javax.swing.plaf.basic.BasicTextUI.setView(BasicTextUI.java:593)
at javax.swing.plaf.basic.BasicTextUI.modelChanged(BasicTextUI.java:581)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.propertyChange(BasicTextUI.java:1669)
at javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:264)
at javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:232)
at javax.swing.JComponent.firePropertyChange(JComponent.java:3819)
at javax.swing.text.JTextComponent.setDocument(JTextComponent.java:401)
at ro.sync.exml.F.O.W$2.run(Unknown Source)
at ro.sync.ui.E$1.run(Unknown Source)
at ro.sync.ui.E.B(Unknown Source)
at ro.sync.exml.F.O.W.A(Unknown Source)
at ro.sync.exml.F.O.S$7.run(Unknown Source)
at ro.sync.ui.E$1.run(Unknown Source)
at ro.sync.ui.E.B(Unknown Source)
at ro.sync.exml.F.O.S.A(Unknown Source)
at ro.sync.E.C.C$1.run(Unknown Source)
at ro.sync.ui.E$1.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:179)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:478)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Post by sorin_ristache » Fri May 26, 2006 11:31 am

Hello,

Disable the XHTML output view of the Debugger perspective from Options -> Preferences -> XML -> XSLT / FO / XQuery -> Debugger -> Enable XHTML Output and try again. If it works you encountered the same problem as here and here and you have to apply one of the workarounds:

- disable XHTML output in Options -> Preferences -> XML -> XSLT/FO/Xquery -> Debugger;

- run <oXygen/> with Java 1.5.

Regards,
Sorin

muewi
Posts: 26
Joined: Wed Aug 24, 2005 10:47 am

Post by muewi » Fri May 26, 2006 12:35 pm

Hello Sorin,

it is working now with Java 1.5 and XHTML output disabled.
Thanks a lot,

Frank

Post Reply