Profiling attributes suddenly disappeared

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Carl
Posts: 80
Joined: Fri Oct 19, 2018 2:19 am

Profiling attributes suddenly disappeared

Post by Carl » Tue Mar 10, 2020 2:20 am

Until today, I was able to apply profiling attributes by right-clicking the selected text and choosing Edit Profiling Attributes. But for whatever reason, I just see "There are no attribute conditions defined" when I do this.

When I click "Configure profiling attributes and values", the Preferences > Editor > Edit Modes > Author > Profiling/Conditional Text page opens. There under "Profiling Attributes", I see that my attributes are still there in the list:

Document type: DITA
Attribute: props
Values: show, hide, etc.

Can you tell me what happened? Why is my "props" no longer showing when I right-click?

Radu
Posts: 7032
Joined: Fri Jul 09, 2004 5:18 pm

Re: Profiling attributes suddenly disappeared

Post by Radu » Tue Mar 10, 2020 5:45 pm

Hi Carl,

In the Oxygen main menu Window->'Show view' you can show the Properties view.
The open a DITA topic and the Properties view should show you the name of the matched document type association.
Then go again to "Preferences > Editor > Edit Modes > Author > Profiling/Conditional Text", edit each profiling attribute and make sure its defined Document Type matches the document type name from the Properties view. By default the document type name for a profiling attribute is set to *DITA* to match any document type containing "DITA" in its name (including DITA Map).

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Carl
Posts: 80
Joined: Fri Oct 19, 2018 2:19 am

Re: Profiling attributes suddenly disappeared

Post by Carl » Tue Mar 10, 2020 9:35 pm

Thanks Radu, that worked!

Turns out I had created a new DITA document type based on your solution to another question I had (about forcing the editor to do line breaks, even in a code block). This broke the link to the profiling attributes.

Oddly enough, my Preferences were showing just "DITA" as the document type for my profiling attributes. Changing it to "*DITA*" fixed it.

Menries
Posts: 1
Joined: Tue Mar 10, 2020 3:05 pm

Re: Profiling attributes suddenly disappeared

Post by Menries » Wed Mar 11, 2020 4:23 pm

Was everything in order when you fixed the link issue, Carl?

Carl
Posts: 80
Joined: Fri Oct 19, 2018 2:19 am

Re: Profiling attributes suddenly disappeared

Post by Carl » Wed Mar 11, 2020 7:00 pm

Yes, things worked normally again when I changed the DITA Type Document from "DITA" to "*DITA*", or when I changed it to the actual custom DITA document that I had created (it's better to use "*DITA*" though).

Radu said the preferences should have defaulted to "*DITA*" in the first place, but mine was "DITA".

Post Reply