No string named 'search.query' was found

catherine
Posts: 139
Joined: Fri Nov 10, 2017 8:16 am

No string named 'search.query' was found

Post by catherine » Wed Feb 19, 2020 10:08 am

When I generate the webhelp, this warning appears:
[DOTX052W]: No string named 'search.query' was found when creating generated text; using the value 'search.query' in your output file.

I did the following operations then this problem occured:
1. added a string-zh-cn.xml in this path: DITA-OT-DIR / plugins / [WebHelp_Directory] / oxygen-webhelp / resources / localization
2. edited strings.xml, added the sentence: <lang xml:lang="zh-cn" filename="strings-zh-cn.xml"/>
3. set args.default.language to zh-cn
4. Checked the option "Run DITA-OT Integrator" in the transformation screen.
5. generated the webhelp

How to solve my problem, thanks.

Regards.
Catherine

ionela
Posts: 347
Joined: Mon Dec 05, 2011 6:08 pm

Re: No string named 'search.query' was found

Post by ionela » Wed Feb 19, 2020 12:56 pm

Hi Catherine,

It seems that you've modified the oXygen XML WebHelp plugin resources. To localize WebHelp interface you need to create your own extension plugin (without modified the built-in one), following this procedure from our user manual:
How to Localize the Interface of WebHelp Responsive Output

Please make sure you follow this procedure on a clean oXygen XML WebHelp plugin installation (not in the altered one) and it should work.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

catherine
Posts: 139
Joined: Fri Nov 10, 2017 8:16 am

Re: No string named 'search.query' was found

Post by catherine » Thu Feb 20, 2020 2:54 pm

Hi, Ionela
Thanks for your help.
My problem is solved by following the documentation.

Post Reply