Cannot hide WebHelp tooltips

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
davenz
Posts: 8
Joined: Mon Mar 11, 2019 11:53 am

Cannot hide WebHelp tooltips

Post by davenz » Sun Dec 08, 2019 10:47 pm

Hi all,

If I set webhelp.publication.toc.tooltip.position to hidden, Oxygen XML Editor still shows the tooltip in the WebHelp output.

If I set the parameter to any other value (such as left or right), the tooltip position does change. It's just that setting the parameter to hidden doesn't hide the tooltip.

Am I missing something?

I'm testing this on Oxygen XML Editor 21.1 with the DITA Map WebHelp Responsive theme.

Thanks,
Dave

Costin
Posts: 677
Joined: Mon Dec 05, 2011 6:04 pm

Re: Cannot hide WebHelp tooltips

Post by Costin » Mon Dec 09, 2019 11:30 am

Hi davenz,

Thank you for reporting this!
I confirm this seems to be a bug, so I've just logged it in our internal issues tracking system to be analyzed by the development team for a fix.
We will notify this thread when the fix will be implemented.

Meanwhile, a simple workaround is to use the following CSS rule in a customization CSS:

Code: Select all

*[class~="topicref"][data-state~="expanded"] *[class~="wh-tooltip"]{
	display: none;
}
To use a customization CSS, you could edit the transformation scenario, then set the "args.css" parameter's value to the path of your own customization .css file that contains the above mentioned rule and also set the "args.copycss" parameter to "yes", or pass the publishing template to your own publishing template (if applicable / in case you are using a publishing template).

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support

davenz
Posts: 8
Joined: Mon Mar 11, 2019 11:53 am

Re: Cannot hide WebHelp tooltips

Post by davenz » Mon Dec 09, 2019 10:59 pm

Great—thanks for confirming and the workaround.

Cheers,
Dave

Post Reply