Problems with svg in pdf2 by migrating to OT release 3.4 (from 3.3.4)

Apollo102
Posts: 6
Joined: Mon Nov 26, 2018 12:56 am

Problems with svg in pdf2 by migrating to OT release 3.4 (from 3.3.4)

Post by Apollo102 » Fri Nov 15, 2019 10:52 am

Hello,

in OT 3.4 my svg files in pdf2 are no longer rendered.

Code: Select all

<step><cmd>svg</cmd><info><image href="warning.svg"></image></info></step>        
<step><cmd>svg-container</cmd>
		<info>
			<svg-container><svgref  href="warning.svg"   format="svg"  /></svg-container>
		</info>
</step>
I also get a crash in other cases (own specialization in which svg files are included in XSLT as:

Code: Select all

<fo:instream-foreign-object xmlns:svg="http://www.w3.org/2000/svg" >)

Message in log:
dita-ot-3.4_test\plugins\org.dita.pdf2.fop\build_fop.xml:145: java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument

I can fix this once the xml-apis-ext-1.3.04.jar is reattached:

Code: Select all

<feature extension="dita.conductor.lib.import" file="lib/xml-apis-ext-1.3.04.jar"/>

The comparison to OT 3.3.4 in plugins\org.dita.pdf2.fop\plugin.xml shows that the xml-apis-ext-1.3.04.jar is no longer used in 3.4. Seems to be a problem.

Regards,

Apollo

Radu
Posts: 7028
Joined: Fri Jul 09, 2004 5:18 pm

Re: Problems with svg in pdf2 by migrating to OT release 3.4 (from 3.3.4)

Post by Radu » Mon Nov 18, 2019 11:42 am

Hi Apollo,

Thanks for the report, I have not yet had a change to look into working with DITA OT 3.4 and Oxygen but I added an issue here:

https://github.com/dita-ot/dita-ot/issues/3414

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply