XSLT validation annoyance

Here should go questions about transforming XML with XSLT and FOP.
jdwinfodesign
Posts: 1
Joined: Fri May 31, 2019 5:21 pm

XSLT validation annoyance

Post by jdwinfodesign » Mon Sep 30, 2019 6:45 pm

"There is no documentation for the template... ."

Looked in Options>Preferences>Editor>Content Completion>XSLT, don't see any way to turn off this particular message without turning off validation altogether. Any way to do so other than adding more lines to my XSLT?

tavy
Posts: 202
Joined: Thu Jul 01, 2004 12:29 pm

Re: XSLT validation annoyance

Post by tavy » Tue Oct 01, 2019 8:52 am

Hello,

Thanks for your feedback.
This type of warning is presented only if you are using "xd:doc" element to document your stylesheet, but you didn't add documentation for all your templates and functions.

To deactivate the Schematron checks for XSLT you need to go to Option-Preferences->Document Type Association options page, then edit the XSLT document type, and in the Validation tab uncheck the "XSLT" validation scenario to be used as default scenario. In the "XSLT" scenario are defined the Schematron rules. In case you want to use them later you can activate them by setting back the default scenario.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply