XHTML 5 document not behaving as XML

deadbeat
Posts: 1
Joined: Fri Aug 09, 2019 4:44 pm

XHTML 5 document not behaving as XML

Post by deadbeat » Fri Aug 09, 2019 5:04 pm

Hi
I am working on an XHTML5 document and, particularly in Author mode, the document is not being treated as an XML document.

The document starts with the required bits to identify it as an XHTML5 document (I used the framework template):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">

I am using the *.html file extension.

I am experiencing a number of things, including:
  • Copy and paste in Author mode, the pasted content is stripped of all markup
  • Empty namespace attributes are being added randomly (xmlns="")
  • Tag completion is working randomly (in text mode and author mode)
It feels as though Oxygen can't decide whether my document is an XHTML5 (XML) or an HTML5 (SGML) document.
I am using XML Editor 21.1, build 2019071807.

Is there anything I can do to improve things? I am close to switching to another Editor.

tavy
Posts: 184
Joined: Thu Jul 01, 2004 12:29 pm

Re: XHTML 5 document not behaving as XML

Post by tavy » Mon Aug 12, 2019 9:48 am

Hello,

Thanks for your feedback.
If you are editing an XHTML document I recommend to use the XHTML Editor. By default the ".html" extension is associated with the HTML Editor, and there are some issues with the editing in the HTML Editor Author page (they will be fixed for the next Oxygen release).

In order to open your file directly in the XHTML Editor, you can go to the Project View, select the file, and use the "Open With->Internal Editor" contextual menu action. In the "Open as" dialog select "XHTML" as editor to open with. You can also check "Associate file type with editor" in case you always want to to open the ".html" files in the XHTML Editor.

Another way to change the association is to go to Options->Preferences dialog, then select "File Types" options page. In the option page select and edit the "html" extension association, and change the editor to XHTML Editor. You can do the same thing for the "htm" extension.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply