Webhelp Responsive - svg.dita.indexterms error

bloodnok
Posts: 36
Joined: Mon Jun 27, 2011 10:51 pm

Webhelp Responsive - svg.dita.indexterms error

Post by bloodnok » Wed Jun 12, 2019 6:52 pm

When building my webhelp project, the processor is throwing an error:

Code: Select all

[exec]  [pipeline] I/O error reported by XML parser processing file:/var/folders/1h/ss92rmxj6tg1rx9rfblmmvkw0000gn/T/temp20190612084545324/svg.dita.indexterms: /var/folders/1h/ss92rmxj6tg1rx9rfblmmvkw0000gn/T/temp20190612084545324/svg.dita.indexterms (No such file or directory)
This file and a couple others that get the same error are targets for conrefs but otherwise are not appear to in the output. This error appears harmless but I'm wondering if there's a way to mark these files so that the processor doesn't try to build an indexterms item for them.

ionela
Posts: 297
Joined: Mon Dec 05, 2011 6:08 pm

Re: Webhelp Responsive - svg.dita.indexterms error

Post by ionela » Thu Jun 13, 2019 11:22 am

Hi,

Could you please provide us more details about the context of this problem as we are not aware of such an issue.
What version of oXygen XML do you use? Could you please try to run the WebHelp Responsive transformation scenario on our sample flowers.ditamap and check if the same error occurs?
If this error is specific to a specific ditamap, please send us a sample on our support email address support [AT] oxygenxml [DOT] com so we can reproduce it on our side.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

tks
Posts: 1
Joined: Thu Sep 11, 2014 5:36 am

Re: Webhelp Responsive - svg.dita.indexterms error

Post by tks » Thu Jul 25, 2019 11:08 am

Hello.

I encountered the same problem.

sample DITA Files:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE map PUBLIC "-//OASIS//DTD DITA Map//EN" "map.dtd">
<map>
    <title>root</title>
    <topicref href="home.dita"/><!-- with conkeyref="rc/content" -->
    <keydef keys="rc" href="resource.dita"/><!-- use conkeyref target. no need html output -->
</map>

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE concept PUBLIC "-//OASIS//DTD DITA Concept//EN" "concept.dtd">
<concept id="home">
    <title>HOME</title>
    <shortdesc></shortdesc>
    <conbody>
        <p conkeyref="rc/content" />
    </conbody>
</concept>

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE concept PUBLIC "-//OASIS//DTD DITA Concept//EN" "concept.dtd">
<concept id="resource">
    <title>resource</title>
    <shortdesc></shortdesc>
    <conbody>
        <p id="content">TEXT</p>
    </conbody>
</concept>
build-log:

Code: Select all

...
whr-collect-indexterms.3x:
 [pipeline] Transforming into C:\Workspace\TEST\indexterm-error\temp\webhelp-responsive
 [pipeline] Loading stylesheet C:\Program Files\Oxygen XML Editor 21\frameworks\dita\DITA-OT3.x\plugins\com.oxygenxml.webhelp.responsive\xsl\indexterms\extractIndexterms.xsl
 [pipeline] Processing C:\Workspace\TEST\indexterm-error\temp\webhelp-responsive\home.dita to C:\Workspace\TEST\indexterm-error\temp\webhelp-responsive\home.dita.indexterms
 [pipeline] Loading stylesheet C:\Program Files\Oxygen XML Editor 21\frameworks\dita\DITA-OT3.x\plugins\com.oxygenxml.webhelp.responsive\xsl\indexterms\collectIndexterms.xsl
 [pipeline] Processing C:\Workspace\TEST\indexterm-error\temp\webhelp-responsive\root.ditamap to C:\Workspace\TEST\indexterm-error\out\webhelp-responsive\index.xml
 [pipeline] Generate file:///C:/Workspace/TEST/indexterm-error/temp/webhelp-responsive/home.dita.indexterms
 [pipeline] Generate file:///C:/Workspace/TEST/indexterm-error/temp/webhelp-responsive/resource.dita.indexterms
 [pipeline] I/O error reported by XML parser processing file:/C:/Workspace/TEST/indexterm-error/temp/webhelp-responsive/resource.dita.indexterms: C:\Workspace\TEST\indexterm-error\temp\webhelp-responsive\resource.dita.indexterms (指定されたファイルが見つかりません。)
- oXygen XML Editor 21.1, build 2019071807 (windows 10-64)
- webhelp responsive (default scenario)

alin
Site Admin
Posts: 143
Joined: Thu Dec 24, 2009 11:21 am

Re: Webhelp Responsive - svg.dita.indexterms error

Post by alin » Fri Jul 26, 2019 9:41 am

Hello,

We managed to reproduce the issue on our side and I have logged it in our issue tracking system.
We will let you know when a solution is available.

Regards,
Alin
Alin Balasa
Software Developer
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply