Error message when opening the explorer inside Oxygen

<oXygen/> general issues.
shannonxtreme
Posts: 24
Joined: Fri Aug 24, 2018 4:27 pm

Error message when opening the explorer inside Oxygen

Post by shannonxtreme » Tue Jul 16, 2019 5:20 pm

I keep getting the following error message when I try to open the file explorer within Oxygen XML Editor 21.1:
The drive or network connection that the shortcut '' refers to is unavailable.
The message pops up about 5 or 6 times before the explorer window opens.

To replicate:
Open a ditamap in the editor
Right-click a topic and select Insert After/Insert Before/Append Child > Topic Reference

This issue has happened with two of the 8 people on our team. It was originally on our installation of Oxygen 20.1 and carried over to 21.1.

adrian
Posts: 2548
Joined: Tue May 17, 2005 4:01 pm

Re: Error message when opening the explorer inside Oxygen

Post by adrian » Wed Jul 17, 2019 5:40 pm

Hello,

The message "The drive or network connection that the shortcut '' refers to is unavailable." does not actually belong to Oxygen. The message is from the file browser (JFileChooser ). This JFileChooser component is passing along the message got from Windows API. The issue was introduced in recent versions of Java 8 (8u191 and 8u202). Java 8u202 is bundled with Oxygen v21.0 and v21.1.

This message usually appears if you have broken shortcuts placed in key locations, like Desktop. The message dialog may appear several times (once for each broken shortcut).
Could you please check for orphaned shortcuts on your Desktop. Especially check for shortcuts that may be pointing to locations you no longer have access to (e.g. inaccessible network locations) or shortcuts to files or folders that no longer exist. Remove those shortcuts to avoid the issue.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

shannonxtreme
Posts: 24
Joined: Fri Aug 24, 2018 4:27 pm

Re: Error message when opening the explorer inside Oxygen

Post by shannonxtreme » Wed Jul 17, 2019 9:04 pm

Hi Adrian,

Thanks for the speedy response. I cleared the contents of my Downloads folder and stuff on my desktop. Seems to have worked - thank you!

Post Reply