Using the topicref copy-to attribute with WebHelp output

Questions about XML that are not covered by the other forums should go here.
bmerenbloom
Posts: 2
Joined: Tue Apr 09, 2019 6:38 pm

Using the topicref copy-to attribute with WebHelp output

Post by bmerenbloom » Fri Jun 14, 2019 5:33 pm

My .ditamap has sub-maps. The sub-maps and related files are each stored in different folders of the repository
.
To successfully share a topic in multiple locations of my WebHelp output, I use <topicref "x/y/abc.dita" copy-to="abc.dita"> in the map that's in the folder where the file does not reside.

With the copy-to attribute in a .ditamap, the the transform process generates a local copy of x/y/abc.dita, and when a user clicks the TOC, WebHelp does not get confused and jump the user to the wrong TOC branch.

Here comes the question.

But the links within a shared topic can still jump to the wrong TOC. Can this be fixed?
Maybe I should never put a link within the text of a topic, and rely on TOCs and reltables instead. That would be unfortunate.

ionela
Posts: 296
Joined: Mon Dec 05, 2011 6:08 pm

Re: Using the topicref copy-to attribute with WebHelp output

Post by ionela » Wed Jun 19, 2019 12:06 pm

Hi,

Could you please specify what version of oXygen XML and the build number you currently use? You can find this information in oXygen XML menu Help > About.
Also, to further reproduce and investigate this issue on our side, could you please create a minimal valid sample DITA project and send it to us for analysis at: suppport [AT] oxygenxml [DOT] com.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Post Reply