How to disable MSXML output escaping?

Questions about XML that are not covered by the other forums should go here.
jamesbowers
Posts: 1
Joined: Fri May 03, 2019 3:46 pm

How to disable MSXML output escaping?

Post by jamesbowers » Thu Jun 06, 2019 5:20 pm

I'm writing a simple XML file using the MSXML client for consumption by another program. The problem is on the text attributes of each of my elements, MSXML is deciding to provide escape characters. While this might be okay, the resulting characters are rejected by the other program upon load.

More or less, I need MSXML to leave my text alone, so I can escape the text properly to suit the program my file is getting inputted on. Any ideas on making this happen?

Radu
Posts: 6393
Joined: Fri Jul 09, 2004 5:18 pm

Re: How to disable MSXML output escaping?

Post by Radu » Fri Jun 07, 2019 7:44 am

Hi,

Maybe you could have given a small example with the characters which are escaped.
XSLT processors need to produce valid XML content. So usually various characters like "<" and "&" are required to be escaped in the produced XML text otherwise the produced XML content would not be valid.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply