Opening ulinks in the browser

honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Opening ulinks in the browser

Post by honyk » Thu May 15, 2014 3:23 pm

Dear All,

in my old Oxygen 11 there are chain icons besides <ulink> elements in he Author mode. When this icon is clicked, the target HTML code is downloaded and opened in the Oxygen. Is there any way to change this behaviour to open that URL in a default web browser?

Thanks, Jan

Radu
Posts: 6453
Joined: Fri Jul 09, 2004 5:18 pm

Re: Opening ulinks in the browser

Post by Radu » Fri May 16, 2014 9:00 am

Hi Jan,

I remember we changed the behavior to do exactly what you want (open links to web pages in a web browser) in oxygen 12.1.
So you should try to upgrade to a newer version of Oxygen (current version is 15.2).

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

menkalos
Posts: 5
Joined: Wed May 13, 2015 11:59 pm

Re: Opening ulinks in the browser

Post by menkalos » Thu May 02, 2019 12:21 am

I'm running Oxygen 20, and I'm seeing a related problem. If the URL ends in a filename with .html, then it opens in the browser just fine. For example, https://docs.aws.amazon.com/index.html works fine and opens in the browser.

However, if I try to test the link https://docs.aws.amazon.com (which is 100% legit), it tries to open the link in Oxygen and errors out.

How do I configure Oxygen so ALL http: and https: links (regardless of whether they end in .html or not) open in the default browser?

Thanks much!

sorin_carbunaru
Site Admin
Posts: 245
Joined: Mon May 09, 2016 9:37 am

Re: Opening ulinks in the browser

Post by sorin_carbunaru » Thu May 02, 2019 11:20 am

Hello,

I just tried your URLs on oXygen 20.0 (build 2018032903, reset global options) with the following DocBook 4 article:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN" "http://docbook.org/xml/4.5/docbookx.dtd">
<article>
    <title/>
    <sect1>
        <title/>
        <para><ulink url="https://docs.aws.amazon.com/index.html"/></para>
        <para><ulink url="https://docs.aws.amazon.com/"/></para>
    </sect1>
</article>
They both behaved the same when clicking on the small anchor link in the Author page, and even when pressing Ctrl and then clicking on the URL value in the Text page.

Do you have a customized DocBook framework? Have you edited the DocBook CSS files in any way (perhaps oXygen 20\frameworks\docbook\css\links.css)?

Regards,
Sorin Carbunaru
oXygen XML

Post Reply