Tooltips never disappear

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
martindholmes
Posts: 161
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Tooltips never disappear

Post by martindholmes » Mon Mar 17, 2014 11:09 pm

I remember this happening occasionally in the past, but since upgrading to 15.2 it's been a constant annoyance: the (usually helpful) tooltips that appear when you're editing code refuse to disappear, even when switching between documents, and the only fix seems to be to restart the application. Right now I have "string-join($arg1 as xs:string*, $arg2 as xs:string) as xs:string" painted across the middle of my Oxygen window indelibly. Has anyone else seen this? I'm using 15.2, build 2014013017. I'm downloading the latest update as I write, but I see nothing about this in the brief release notes that show up when you check for updates, and I can't find any more extensive ones.

I'm on Ubuntu 12.04 64-bit with Gnome Shell.

Cheers,
Martin

adrian
Posts: 2703
Joined: Tue May 17, 2005 4:01 pm

Re: Tooltips never disappear

Post by adrian » Tue Mar 18, 2014 3:29 pm

Hi,

We are aware of such an issue (stuck tooltips) occurring when switching the project while the tooltips are visible.
Are you switching the project frequently or does this happen in a different scenario?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

martindholmes
Posts: 161
Joined: Wed Apr 20, 2005 5:43 pm
Location: Victoria, BC, Canada

Re: Tooltips never disappear

Post by martindholmes » Thu Mar 20, 2014 7:36 pm

I do switch projects a lot, but the stuck tooltip doesn't seem to appear or persist after switching; I just switched projects three times this morning, and the first stuck tooltip only appeared several minutes into editing a couple of files in the last project. I can confirm that updating to the latest version doesn't fix it.

adrian
Posts: 2703
Joined: Tue May 17, 2005 4:01 pm

Re: Tooltips never disappear

Post by adrian » Wed Mar 26, 2014 6:45 pm

Hi,

We've seen tooltips getting stuck when they somehow appear on top of a different editor and then the source editor of the tooltip is being closed with middle click on the editor tab or click on the editor close button(x) without switching to that editor first. If you first switch to that editor, you can avoid the problem.
Unfortunately the only solution to get rid of the orphaned tooltips at this time is to restart the application.

We're currently looking into this. We will notify this thread when the bug is resolved.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

charlesh
Posts: 7
Joined: Fri Jan 02, 2015 1:09 pm

Re: Tooltips never disappear

Post by charlesh » Fri Jan 02, 2015 1:29 pm

I'm also seeing this issue (oXygen Eclipse, v15.2). Is there any update you can share on this please?

Thanks,

Charles

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Tooltips never disappear

Post by sorin_ristache » Mon Jan 05, 2015 4:05 pm

Sorry, we encountered this problem in the Oxygen stand-alone application, not in the Oxygen Eclipse plugin. So we will have to investigate it also on the Eclipse platform, not only in the Oxygen stand-alone application.

On what platform do you run Oxygen on the Eclipse platform? If it is a Linux distribution, please tell us the name and version of your Linux distribution. What Eclipse version do you run?

How do you get this problem in Eclipse? In Oxygen stand-alone it was encountered when switching between Oxygen projects in the Project view while a tooltip was visible and also when closing an editor tab with middle click. But the switch between Oxygen projects (.xpr files) is not available in Eclipse and I don't get the tooltip problem when I middle-click on the editor title tab.
Regards,
Sorin

<oXygen/> XML Editor Support

charlesh
Posts: 7
Joined: Fri Jan 02, 2015 1:09 pm

Re: Tooltips never disappear

Post by charlesh » Mon Jan 05, 2015 5:48 pm

Hi Sorin,

I'm using Eclipse 3.5.2 on Windows 7 64 bit.

The issue is easily reproducible for us. In Author Mode, click the mouse at the very start of the topic. A flashing horizontal caret will appear. If you then try to type any characters this will prompt a warning message in the form of a multiline tooltip:
Text is not allowed in element 'reference' (element only or empty or fixed content).

To allow this operation....

Go to preferences...
If I then use the mouse to bring another application into the foreground then the tooltip remains "on top".

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Tooltips never disappear

Post by sorin_ristache » Tue Jan 06, 2015 3:58 pm

Hi Charles,

Yes, I can see the tooltip that remains in the Eclipse editor page when I switch to other applications using the mouse but I can get rid of it with a very simple workaround: switch back to Eclipse (using whatever means) and just switch to other Eclipse editor page and then switch back to the Oxygen Author page.

We will try to remove the "stubborn" tooltip in the first place so that no workarounds are needed.
Regards,
Sorin

<oXygen/> XML Editor Support

jbvalentin
Posts: 11
Joined: Thu Jul 06, 2017 10:53 am
Location: Nantes, France

Re: Tooltips never disappear

Post by jbvalentin » Tue Jul 18, 2017 5:15 pm

Hi,

some of our authors, using the oXygenXML author (DITA authoring, to be more accurate) still experience this annoyance, more or less frequently.

Are there any news regarding this small issue?

Thank you
Jean-Baptiste

Radu
Posts: 7331
Joined: Fri Jul 09, 2004 5:18 pm

Re: Tooltips never disappear

Post by Radu » Wed Jul 19, 2017 8:04 am

Hello Jean-Baptiste,

This thread was for Oxygen 15.x and now the current Oxygen version is 19.x.
Could you tell me what specific tooltip stays on screen? We have lots of tooltips in various places and it would help to know what to test for. A screenshot with the visible tooltip would be enough for us to figure this out. You can also contact us directly (support@oxygenxml.com) to provide these extra details.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

barbk
Posts: 3
Joined: Wed Dec 06, 2017 1:24 am

Re: Tooltips never disappear

Post by barbk » Wed Dec 06, 2017 1:28 am

We are still encountering this issue in Oxygen 18.

Is it fixed in Oxygen 19?

Radu
Posts: 7331
Joined: Fri Jul 09, 2004 5:18 pm

Re: Tooltips never disappear

Post by Radu » Wed Dec 06, 2017 8:54 am

Hi,

Our last effort to fix this problem was in Oxygen 19.1. So if you can update to 19.1 you could test and see if you still have this problem or not.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

thedantanner
Posts: 42
Joined: Thu Oct 27, 2016 11:13 pm

Re: Tooltips never disappear

Post by thedantanner » Tue Jan 29, 2019 9:54 pm

I am experiencing this problem in Oxygen Editor's author view. I'm not exactly sure how to reproduce it, but I'll be watching closely the next time it happens. It doesn't happen all the time, just every so often throughout any given day. So far as I've seen, it only happens in the author view window.


I'm running Oxygen 20.1 on a Windows machine.

sorin_carbunaru
Posts: 355
Joined: Mon May 09, 2016 9:37 am

Re: Tooltips never disappear

Post by sorin_carbunaru » Wed Jan 30, 2019 9:32 am

Hello,

Could you please tell me what kind of tooltips don't disappear? Is it the ones shown when placing the caret inside an element, the ones shown when the content completion assistant is invoked (by pressing Enter), or some other ones?

All the best wishes,
Sorin Carbunaru
oXygen XML

thedantanner
Posts: 42
Joined: Thu Oct 27, 2016 11:13 pm

Re: Tooltips never disappear

Post by thedantanner » Thu Jan 31, 2019 6:13 pm

The only tooltips I've seen hang are when hovering the mouse over an element tag in the author view. I'll send an example to the support email (I have no way of sharing an image on this forum).

sorin_carbunaru
Posts: 355
Joined: Mon May 09, 2016 9:37 am

Re: Tooltips never disappear

Post by sorin_carbunaru » Fri Feb 01, 2019 10:53 am

Me and one colleague of mine tried to reproduce this on our PCs, but we didn't manage to do it... If you can find a way to recreate the problem at least from time to time, please share it with us. :)

Post Reply