log4j configuration

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.

log4j configuration

Post by jens » Fri Sep 19, 2003 7:38 am

I'm currently evaluating eclipse 3.0M2 (Linux/Motif/j2sdk 1.4.2) and the oxygen 2.0.3 plugin,
since some developers asked me, whether it is worth/allowed to use it. So forgive
my newbie questions/problems ;-)

What me especially bothers is, that it takes a long time until e.g. the oxygen xsl editor
comes up and it seems even not to be a more or less constant time. E.g.:
Dual P4, 2.4GHz, 1024 MB RDRAM: several minutes
1 Celeron, 450 MHz, 512 MB SDRAM: 10 -20 seconds

This looks confusing, doesn't it? The eclipse installation incl. oxygen distrib is identical on both machines.

Hmmm, since I see all the time the message:
log4j:WARN No appenders could be found for logger (ro.sync.exml.do).
log4j:WARN Please initialize the log4j system properly.

I tried to get more information to nail down the problem by specifying -vmargs -Dlog4j.configuration=/tmp/log4j.properties, however it has no influence on oxygen.
So I tried to copy the configuration file into a classpath (com.oxygenxml.editor_2.0.3/lib/)
so that log4j should find it automatically and use this for its configuration, but
this doesn't work either :(

Hmmm, so why does this not work? Because oxygen uses the st... avalon stuff?
If so - RFE: please remove the useless wrapper stuff, which just imposes a lot
of overhead and nobody can rely on the log stuff, since it does not work as expected.
Perhaps I'm wrong, but IMHO currently there are only to major logging systems,
which work reliable/efficient/fast - Log4j and JDK1.4 (well, and most people probably
know, which one is the better one/"pseudo standard") ...

BTW: Perhaps the startup time could be decreased by indexing the jar files ... ?