Web help does not display topic title in TOC

Trapeze
Posts: 2
Joined: Wed Nov 21, 2018 7:44 pm

Web help does not display topic title in TOC

Post by Trapeze » Wed Nov 21, 2018 8:18 pm

Using the most current version of oXygen, I've been creating webhelp responsive outputs. I have a problem with one file. In the web help TOC, it displays as an ellipsis (...). All the other files display their title as expected. The title is not particularly long, shorter than many other properly displayed titles. When I click on the ellipsis, the file is properly displayed. When I create a pdf of the same document, the TOC is displayed properly. The file has no discernable DITA errors (I've run validation). I've also erased and rewritten the title without any difference. The file has this problem when published in different ditamaps, so it is not the surrounding files. The problem occurs no matter which webhelp template I use and I have replicated it on different machines. The help generates without any error messages.

Has any one else encountered this problem and have any any idea as to what is causing the problem or how I might go about debugging it.

ionela
Posts: 277
Joined: Mon Dec 05, 2011 6:08 pm

Re: Web help does not display topic title in TOC

Post by ionela » Thu Nov 22, 2018 1:50 pm

Hi,

When you perform the 'DITA Map Validation and Check for Completeness' action could you please make sure that 'Report references to resources outside of the DITA map folder' option is selected?
One possible cause of this problem might be if you have resources located outside of the main DITA map folder.
Using this option you make sure that the validation reports any references to DITA resources that are located outside of the main DITA map directory.
If that's the case, and you run the WebHelp Responsive transformation scenario from oXygen XML GUI, you can set the 'fix.external.refs.com.oxygenxml' parameter to true in the transformation scenario: References Outside the Main DITA Map Folder

If this is not the problem, please create a minimal valid sample project and send it to us by email to support AT oxygenxml DOT com for further investigation.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Trapeze
Posts: 2
Joined: Wed Nov 21, 2018 7:44 pm

Re: Web help does not display topic title in TOC

Post by Trapeze » Fri Nov 23, 2018 9:19 pm

The problem was not the parameters.

I discovered the issue was the metadata for the file. For some reason, this file had metadata which included a blank navtitle entry, like this

<navtitle></navtitle>

There was other metadata and the syntax was correct. But the blank navtitle seems to override the file title in the webhelp TOC.

radu_pisoi
Posts: 343
Joined: Thu Aug 21, 2003 11:36 am
Location: Craiova
Contact:

Re: Web help does not display topic title in TOC

Post by radu_pisoi » Mon Nov 26, 2018 2:46 pm

Hi,

This is the desired behavior, the navtitle specified in the DITA map overrides the topic's title.

See more details in DITA specification:
https://www.oxygenxml.com/dita/1.3/spec ... title.html
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply