Image as link - odd behavior

mdslup
Posts: 99
Joined: Tue Mar 06, 2018 1:34 am

Image as link - odd behavior

Post by mdslup » Fri Oct 26, 2018 12:33 am

Here is my DITA code to turn an image into a link.

<xref
href="https://www.google.com"
format="html"
scope="external">
<image
href="images/google-play-badge.png"
id="image_oqh_nfz_4fb"/>
</xref>

In the generated HTML, clicking the image opens the link in a new tab/window, which is what I want. But, in the current window, it opens a large version of the image. I traced this back to a javascript event listener that is added by jquery-3.1.1.min.js.

How can I disable the behavior of opening a large tab in the current window, while maintaining the functionality of opening the link in a new tab?

Thanks.

ionela
Posts: 255
Joined: Mon Dec 05, 2011 6:08 pm

Re: Image as link - odd behavior

Post by ionela » Fri Oct 26, 2018 4:41 pm

Hello,

Thank you for feedback.

I confirm this is a bug in the current WebHelp Responsive implementation. I have logged it to our issue tracking tool in order to be analyzed and resolved by our development team.
We'll update the thread when the bugfix becomes available.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

mdslup
Posts: 99
Joined: Tue Mar 06, 2018 1:34 am

Re: Image as link - odd behavior

Post by mdslup » Fri Oct 26, 2018 8:59 pm

That's a relief actually...I was afraid that I'd forgotten how to do basic editing :)

Thanks for letting me know. If a nightly build becomes available that fixes this bug, can you please let me know?

ionela
Posts: 255
Joined: Mon Dec 05, 2011 6:08 pm

Re: Image as link - odd behavior

Post by ionela » Mon Oct 29, 2018 12:13 pm

Hi,

I've added your comments to our issue tracking tool, so we'll contact you by email when a nightly build contains this bugfix.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

sorin_carbunaru
Site Admin
Posts: 204
Joined: Mon May 09, 2016 9:37 am

Re: Image as link - odd behavior

Post by sorin_carbunaru » Mon Feb 25, 2019 5:33 pm

Hi,

Just wanted to let everyone know that this was fix in oXygen 20.1, and it's of course also fixed in the newly released oXygen 21.

Best wishes,
Sorin Carbunaru
oXygen XML

Post Reply