XSPEC output

Here should go questions about transforming XML with XSLT and FOP.
Fredrik_Lönn
Posts: 29
Joined: Mon Feb 06, 2017 11:47 am

XSPEC output

Post by Fredrik_Lönn » Fri Jun 29, 2018 3:59 pm

Hi,

I am trying to use XSPEC for testing some XSLT files and have run into an issue.

For one XSLT file I have three scenarios. Two of these pass, but one fails. Now I am trying to debug...
  • The html report that is generated links to a result file that does not exist.
  • I use the "XSpec for XSLT" scenario, but find no documentation of some of the listed parameters. I am trying to find a way to save the generated XML code for inspection.
  • I tried to install the "XSpec Framework" and "XSpec Helper view" addons, but the xspec file will not run due to missing my XSLT file. It seems to be looking for it in a non-existing "xspec" folder.
Documentation seems a little sparse, so any advice would be appreciated. I include the output from the ANT window when trying to use the addons:
Executing:
"c:\program files\oxygen xml editor 20\jre/bin/java" -Dfile.encoding=UTF-8 -Xmx256m -classpath "C:\Program Files\Oxygen XML Editor 20\tools\ant/lib/ant-launcher.jar" "-Dant.home=C:\Program Files\Oxygen XML Editor 20\tools\ant" org.apache.tools.ant.launch.Launcher -lib "C:\Program Files\Oxygen XML Editor 20\classes" -lib "C:\Program Files\Oxygen XML Editor 20\lib\oxygen.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\oxygenAuthor.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\oxygenDeveloper.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\oxygenEclipse.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\oxygenAuthorEclipse.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\oxygenDeveloperEclipse.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\xml-apis.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\resolver.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\saxon9ee.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\log4j.jar" -lib "C:\Program Files\Oxygen XML Editor 20\lib\xercesImpl.jar" -f "oxygen-results-view/build_report.xml" "-Dcatalog=C:\Users\fkln\pim_new\ffpdx\filters/catalog.xml" "-Dclean.output.dir=true" "-Dcompile.xspec.xsl=C:/Users/fkln/AppData/Roaming/com.oxygenxml/extensions/v20.1/frameworks/https___www.oxygenxml.com_InstData_Addons_community_updateSite.xml/xspec.support-0.0.11/oxygen-results-view/generate-xspec-tests-oxygen.xsl" "-Dformat.xspec.report=C:/Users/fkln/AppData/Roaming/com.oxygenxml/extensions/v20.1/frameworks/https___www.oxygenxml.com_InstData_Addons_community_updateSite.xml/xspec.support-0.0.11/oxygen-results-view/unit-report-oxygen.xsl" "-Dtest.type=t" "-Dxspec.fail=false" "-Dxspec.project.dir=C:/Users/fkln/AppData/Roaming/com.oxygenxml/extensions/v20.1/frameworks/https___www.oxygenxml.com_InstData_Addons_community_updateSite.xml/xspec.support-0.0.11/" "-Dxspec.result.html=C:\Users\fkln\pim_new\ffpdx\filters/supplier_filter-report.html" "-Dxspec.template.name.entrypoint=" "-Dxspec.xml=C:\Users\fkln\pim_new\ffpdx\filters\supplier_filter.xspec" "-Dwebhelp.trial.license=no"

Buildfile: C:\Users\fkln\AppData\Roaming\com.oxygenxml\extensions\v20.1\frameworks\https___www.oxygenxml.com_InstData_Addons_community_updateSite.xml\xspec.support-0.0.11\oxygen-results-view\build_report.xml

locateSchematron:

getSchematronPhase:

compileSchematron:

xspec:
[echo] Creating Test Stylesheet...
[echo] Clean up
[delete] Deleting directory C:\Users\fkln\pim_new\ffpdx\filters\xspec
[echo] Step 1. Compile the XSPEC into an XSLT
[echo] Saxon config: C:/Users/fkln/AppData/Roaming/com.oxygenxml/extensions/v20.1/frameworks/https___www.oxygenxml.com_InstData_Addons_community_updateSite.xml/xspec.support-0.0.11//oxygen-results-view/saxon-config.xml
[java] Exception in thread "main" java.lang.NoClassDefFoundError: ro/sync/basic/util/Crypto
[java] at ro.sync.xml.transformer.n.f(Unknown Source)
[java] at ro.sync.xml.transformer.saxonee.SaxonEEUtilImpl.supplySaxonLicenseAndSchemaResolver(Unknown Source)
[java] at net.sf.saxon.Configuration.newConfiguration(Unknown Source)
[java] at net.sf.saxon.Configuration.readConfiguration(Unknown Source)
[java] at net.sf.saxon.Transform.doTransform(Transform.java:303)
[java] at net.sf.saxon.Transform.main(Transform.java:81)
[java] Caused by: java.lang.ClassNotFoundException: ro.sync.basic.util.Crypto
[java] at java.net.URLClassLoader.findClass(Unknown Source)
[java] at java.lang.ClassLoader.loadClass(Unknown Source)
[java] at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
[java] at java.lang.ClassLoader.loadClass(Unknown Source)
[java] ... 6 more
[java] Java Result: 1
[echo] Step 2. Create the Driver XSLT
[echo] Apply driver to execute the templates:

BUILD FAILED
C:\Users\fkln\AppData\Roaming\com.oxygenxml\extensions\v20.1\frameworks\https___www.oxygenxml.com_InstData_Addons_community_updateSite.xml\xspec.support-0.0.11\oxygen-results-view\build_report.xml:319: A source file is missing: C:\Users\fkln\pim_new\ffpdx\filters\xspec\supplier_filter.xsl

Total time: 1 second

The process finished with exit code: 1

alex_jitianu
Posts: 697
Joined: Wed Nov 16, 2005 11:11 am

Re: XSPEC output

Post by alex_jitianu » Mon Jul 02, 2018 3:50 pm

Hello,
The html report that is generated links to a result file that does not exist.
Can you send me some sample files on support@oxygenxml.com so I can reproduce the same behavior and try to understand what is happening?
I use the "XSpec for XSLT" scenario, but find no documentation of some of the listed parameters. I am trying to find a way to save the generated XML code for inspection.
You probably need to set clean.output.dir parameter to false. The intermediate files can be found in a directory named "xspec" right next to the xspec file.
I tried to install the "XSpec Framework" and "XSpec Helper view" addons, but the xspec file will not run due to missing my XSLT file. It seems to be looking for it in a non-existing "xspec" folder.
I made a new release of the plugin, version 1.0.0, that should fix this issue. To update, go to Help->Check for addons updates... and follow the update procedure.

Best regards,
Alex

Fredrik_Lönn
Posts: 29
Joined: Mon Feb 06, 2017 11:47 am

Re: XSPEC output

Post by Fredrik_Lönn » Thu Jul 05, 2018 12:04 pm

Hi Alex,

I have done some further work on this and figured out as you propose that I should set the mentioned parameter to False.

This helped me to review the resulting xml file and it is obvious that it differs very much from my "own" result when applying the XSLT to the xml file. The result generated by the xspec process does not seem to apply any of my templates. My XSLT file starts by assigning an xpath expression to a variable and it is my guess that it is the value of this variable that differs.

Code: Select all


    <xsl:variable name="CompetingMLItems"
select="<xpath expression>"
</xsl:variable>

<!-- Example of template -->
<xsl:template match="
/ProductDataeXchangePackage/ManufacturerParts/ManufacturerPart
[
@manufacturerPartUniqueIdentifier=
$CompetingMLItems/@manufacturerPartUniqueIdentifier
]
" priority="94"/>
</xsl:template>
At this stage I have given up on xspec, because does not seem straightforward to test any XSLT code. This might be a misunderstanding on my part, since I have spent only a handful of hours trying out xspec. I think I would need a better introduction than I could find, to be able to make proper use of it.

alex_jitianu
Posts: 697
Joined: Wed Nov 16, 2005 11:11 am

Re: XSPEC output

Post by alex_jitianu » Thu Jul 05, 2018 3:54 pm

Hi Fredrik,

I'm sorry to hear that... Nevertheless, my offer still stands. You can send me the XSpec file together with the XSLT on support@oxygenxml.com and I will try to see why it doesn't work. Rest assure, once I make the tests, I will remove the files from my system.

Best regards,
Alex

Post Reply