Unknown system function: tokenize - error

Here should go questions about transforming XML with XSLT and FOP.
giyu
Posts: 6

Unknown system function: tokenize - error

Wed Jun 13, 2018 10:02 pm

When I run the debugger, I get an error
"System ID: C:\repos\ditaws\mainline\DITA-OT1.8\plugins\com.qnx.dita.transform.safetytables\xsl\formatfunction.xsl
Severity: fatal
Description: Error in expression tokenize($argstring,','): Unknown system function: tokenize
Start location: 50:0
"

I tried switching the XLST version from 1.0 to 2.0 and 3.0, but still get the same issue.
I tried switching up the Engine used with XSLT Valiation in the Options -> Preferences -> XML -> XSLT-FO-XQuery -> XSLT, but still get the same error. Any ideas?

I am able to run this using the <xslt> command in ant (version 1.7).
Radu
Posts: 5630

Re: Unknown system function: tokenize - error

Thu Jun 14, 2018 3:03 pm

Hi,

On what XSLT stylesheet do you run the debugger? Probably on that stylesheet you should change the XSLT version.
The XSLT 1.0 standard does not have the "tokenize" method. When debugging, in the debugger perspective there is an XSLT engine combo box in which you can choose between the default Saxon 6.5.5 (which only knows XSLT 1.0) and Saxon 9.8 PE (or EE) which can also do XSLT 2.0 (and 3.0). So you should change that instead of changing those preference settings.

If that does not work:
Could you maybe try to create a small set of XSLT sample code exemplifying the situation? Have a main XSLT and import in it the module XSLT, then give me some steps to reproduce the problem on my side.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “XSLT and FOP”

Who is online

Users browsing this forum: No registered users and 2 guests