Dotted line in my TOC under Linux on command line and not with Oxygen

Here should go questions about transforming XML with XSLT and FOP.
marcbenfatma
Posts: 1
Joined: Thu May 31, 2018 5:20 pm

Dotted line in my TOC under Linux on command line and not with Oxygen

Post by marcbenfatma » Thu May 31, 2018 5:26 pm

Hello,

I have an annoying bug :( I have a standard map like this :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE map PUBLIC "-//OASIS//DTD DITA Map//EN" "map.dtd">
<map xml:lang="fr">
<title>title</title><topicref href="topics/topic.dita"/>
<topicref href="topics/topic.dita"/>
<topichead><topicmeta><navtitle>Bonjour</navtitle></topicmeta>
<topicref href="topics/topic.dita">
<topicref href="topics/topic.dita"/>
<topicref href="topics/topic.dita"/>
</topicref>
</topichead>
</map>

When I generate the PDF with my own plugin on Oxygen, the table of contents is perfect.
But when I generate it on Linux in command line I have lines of dots in my table of contents :

SOMMAIRE
..........................................................................................................................................................................................
.....................................................................................................................................................................
..........................................................................................................................................................................................
1. yttuytuyt.....................................................................................................................................4
2. yuytu..................................................................................................................... 5

I tried many things without success ...
If someone have an idea it would be great.
Thanks for any help.