File not found error in web help (command line)

Posts: 9

File not found error in web help (command line)

Thu Apr 12, 2018 2:20 am

I am publishing web help responsive from the command line using the standalone web help plugin. Here are the details:
- DITA-OT 2.5.2
- Webhelp licence for version 19.1

When I try to publish web help responsive output from the command line using an ant script, I get no tiles on the first page (index.html) and the title of the help does not appear (in its place is "*** unable to determine the map title").

In my output log, I notice the following errors:

[taskdef] Could not load definitions from resource net/sf/antcontrib/antlib.xml. It could not be found.

[xslt] C:\Users\name\git\dita-ot-2.5.2\plugins\com.oxygenxml.webhelp.responsive\xsl\dita2webhelp\dita2webhelpImpl.xsl:49: Error! \out\toc.xml (The system cannot find the file specified) Cause: \out\toc.xml (The system cannot find the file specified)

[xslt] C:\Users\name\git\dita-ot-2.5.2\plugins\com.oxygenxml.webhelp.responsive\xsl\mainFiles\createIndextermsPageImpl.xsl:52: Error! \out\index.xml (The system cannot find the file specified) Cause: \out\index.xml (The system cannot find the file specified)

Can you please have a look and let me know the issue? Thanks.
Posts: 472

Re: File not found error in web help (command line)

Thu Apr 12, 2018 12:12 pm

Hi jlowther,

From the errors you receive, you might be using the DITA-OT that came bundled with an oXygen XML Editor or XML Author installation, or a DITA-OT that might have been tinkered with.
However, the suggestion is to download a fresh clean copy of the DITA-OT 2.5.2 from the official download page on GitHub, extract it to a location of your choice, then install the WebHelp plugin inside it.

Also, in case you have a v20 compatible oXygen license, you should download and install the latest version of oXygen, as in this way you could use the new "Publishing Templates" support in oXygen to create/fine tune a WebHelp Responsive template, which could then be saved and used by the WebHelp plugin, in your command line to tailor your output as you need.
More information about the new Publishing Templates support, as well as a new video demonstration available in the User-Guide.

Let me know if you encounter further issue, even after installing WebHelp in a clean DITA-OT distribution.

Costin Sandoi
oXygen XML Editor and Author Support
Posts: 69

Re: File not found error in web help (command line)

Wed Apr 18, 2018 11:47 pm

I'm am also running into an issue with the antlib.xml file not being found. I downloaded a clean copy of OT 2.5.2 as suggested above as well.

I even explicitly edited the path to the ant-contrib file from this,

Code: Select all

<pathelement location="${webhelp.responsive.dir}/lib/ant-contrib-1.0b3.jar"/>

to this

Code: Select all

<pathelement location="${dita.dir}/plugins/com.oxygenxml.webhelp.responsive/lib/ant-contrib-1.0b3.jar"/>

What are the dependencies for this file? Does this require a Javaclass or Ant batch file to work properly?

I'm installing this on our CCMS server after first testing it on my local system. Do have the license to install it here too.
Posts: 243

Re: File not found error in web help (command line)

Thu Apr 19, 2018 2:51 pm


Could you please let us know what version of oXygen XML WebHelp plugin have you tried to use?
I have tried the procedure described in our user manual for oXygen XML WebHelp plugin v20.0 and DITA-OT 2.5.2 as described in the thread below and it worked for me:

Also, you shouldn't manually edit the ant-contrib file, just make sure you run the dita.bat --install script. This way the Oxygen XML WebHelp plugin will be integrated with the DITA-OT.

Ionela Istodor
oXygen XML Editor and Author Support

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 3 guests