Running Saxon 9.8 EE in oXygen 20 with streaming disabled

Here should go questions about transforming XML with XSLT and FOP.
Martin Honnen
Posts: 55
Joined: Tue Aug 19, 2014 12:04 pm

Running Saxon 9.8 EE in oXygen 20 with streaming disabled

Post by Martin Honnen » Fri Mar 16, 2018 6:21 pm

I am exploring how to use Saxon 9.8 EE in oXygen 20 with stylesheets that use streaming. As using streaming is a new feature that is difficult to understand and requires redeveloping your XSLT skill set and as furthermore sometimes Saxon gives different results when using streaming compared when not using it it seems desirable to me to be able to use Saxon 9.8 EE as the transformation engine but be able to disable streaming for a run, like the configuration feature STREAMABILITY:off allows with Saxon.

It seems currently, when I use Saxon 9.8 EE as the transformation engine and have not set the advanced option "Enable streaming mode" but then try to run a stylesheet using a streamable mode I simply get an error "The unnamed mode is streamable, but the input is not supplied as a stream. Edit the transformation scenario and select the option "Enable streaming mode" in the configuration of the Saxon transformer engine.".

As said, for testing it can be desirable to use Saxon 9.8 EE but disable streaming temporarily, is there any way doing that inside oXygen 20?

alex_jitianu
Posts: 688
Joined: Wed Nov 16, 2005 11:11 am

Re: Running Saxon 9.8 EE in oXygen 20 with streaming disabled

Post by alex_jitianu » Mon Mar 19, 2018 5:14 pm

Hi Martin,

Thank you for reporting this behavior. This options is not a synonym for Saxon's STREAMABILITY option. It is something extra that one has to activate inside Oxygen if he wants to use Saxon in streaming mode. It has something to do with Saxon's JAXP implementation but there's no point going into details. I will add an issue for us to ponder a bit and decide how to express this fact as well as allowing users to run Saxon in a STREAMABILITY:off mode.

Meanwhile, what you can do is to create a Saxon configuration file with this content:

Code: Select all

<configuration edition="EE" xmlns="http://saxon.sf.net/ns/configuration">
<global streamability="off"/>
<xslt/>
</configuration>
and specify it inside the scenarios advanced options.


Best regards,
Alex

Post Reply